Bug 440090 - X crashes when i try to watch video
X crashes when i try to watch video
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-01 14:14 EDT by Siim Käba
Modified: 2008-04-02 18:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 18:52:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Siim Käba 2008-04-01 14:14:03 EDT
Description of problem:
X crashes when i try to watch video.

Version-Release number of selected component (if applicable):
latest updated fedora 8
[root@nokkel ~]# rpm -qa | grep -i xorg
xorg-x11-apps-7.3-1.fc8.x86_64
xorg-x11-server-utils-7.3-2.fc8.x86_64
xorg-x11-drv-radeonhd-1.1.0-0.7.20080301git.fc8.x86_64
xorg-x11-drv-fglrx-libs-8.471-1.8.03.lvn8.x86_64
xorg-x11-utils-7.3-1.fc8.x86_64
xorg-x11-drv-mouse-1.2.3-1.fc8.x86_64
xorg-x11-server-sdk-1.3.0.0-44.fc8.x86_64
xorg-x11-font-utils-7.2-2.fc8.x86_64
xorg-x11-xdm-1.1.6-2.fc8.x86_64
xorg-x11-drv-vesa-1.3.0-10.fc8.x86_64
xorg-x11-drv-vga-4.1.0-5.fc8.x86_64
xorg-x11-drv-fglrx-libs-8.471-1.8.03.lvn8.i386
xorg-x11-filesystem-7.1-2.fc6.noarch
xorg-x11-fonts-Type1-7.2-3.fc8.noarch
xorg-x11-drv-evdev-1.1.2-5.fc8.x86_64
xorg-x11-drv-dummy-0.2.0-5.fc8.x86_64
xorg-x11-xinit-1.0.7-2.fc8.x86_64
xorg-x11-drv-fbdev-0.3.1-4.fc8.x86_64
xorg-x11-util-macros-1.1.5-1.fc7.x86_64
xorg-x11-xkb-utils-7.2-3.fc8.x86_64
xorg-x11-server-Xorg-1.3.0.0-44.fc8.x86_64
xorg-x11-drv-fglrx-8.471-1.8.03.lvn8.x86_64
xorg-x11-fonts-misc-7.2-3.fc8.noarch
xorg-x11-fonts-ISO8859-1-100dpi-7.2-3.fc8.noarch
xorg-x11-fonts-100dpi-7.2-3.fc8.noarch
xorg-x11-drv-keyboard-1.2.2-2.fc8.x86_64
xorg-x11-fonts-ISO8859-1-75dpi-7.2-3.fc8.noarch
xorg-x11-proto-devel-7.3-3.fc8.noarch
xorg-x11-xauth-1.0.2-3.fc8.x86_64
xorg-x11-fonts-truetype-7.2-3.fc8.noarch
xorg-x11-fonts-75dpi-7.2-3.fc8.noarch
xorg-x11-drv-void-1.1.1-6.fc8.x86_64
xorg-x11-xfs-1.0.5-1.fc8.x86_64

[root@nokkel ~]# rpm -qa | grep -i fglrx
xorg-x11-drv-fglrx-libs-8.471-1.8.03.lvn8.x86_64
kmod-fglrx-8.471-3.8.03.lvn8.x86_64
xorg-x11-drv-fglrx-libs-8.471-1.8.03.lvn8.i386
xorg-x11-drv-fglrx-8.471-1.8.03.lvn8.x86_64
kmod-fglrx-2.6.24.3-50.fc8-8.471-3.8.03.lvn8.x86_64
kmod-fglrx-2.6.24.3-34.fc8-8.471-2.8.03.lvn8.x86_64 <- this one

How reproducible:
100%

Steps to Reproduce:
1. try to open skype with video...
2. or with mplayer 
3. or with firefox video plugin
  
Actual results:
(II) <default pointer>: ps2EnableDataReporting: succeeded
ProcXCloseDevice to close or not ?
SynapticsCtrl called.
SynapticsCtrl called.

Backtrace:
0: /usr/bin/X(xf86SigHandler+0x6d) [0x47fe0d]
1: /lib64/libc.so.6 [0x3731c30f30]
2: /usr/lib64/xorg/modules//glesx.so [0x2aaaaeb8ac82]
3: /usr/lib64/xorg/modules//glesx.so [0x2aaaaeb894fa]
4: /usr/lib64/xorg/modules//glesx.so [0x2aaaaeb8898a]
5: /usr/lib64/xorg/modules//glesx.so [0x2aaaaeb872f9]
6: /usr/lib64/xorg/modules//glesx.so [0x2aaaaeb87951]
7: /usr/bin/X [0x492f8a]
8: /usr/lib64/xorg/modules/extensions//libextmod.so [0x2aaaaad98ebd]
9: /usr/bin/X(Dispatch+0x1db) [0x44a54b]
10: /usr/bin/X(main+0x465) [0x4332b5]
11: /lib64/libc.so.6(__libc_start_main+0xf4) [0x3731c1e074]
12: /usr/bin/X(FontFileCompleteXLFD+0x259) [0x432579]

Fatal server error:
Caught signal 11.  Server aborting

(II) AIGLX: Suspending AIGLX clients for VT switch

Expected results:
not to crash.

Additional info:
ask and i'll provide.
Comment 1 Matěj Cepl 2008-04-02 18:52:20 EDT
Thanks for the report. We are sorry that we cannot help you with your problem,
but we are not able to support binary-only drivers. If you would be able to
reproduce this issue using only open source software, please, reopen this bug
with the additional information, but in meantime I have no choice than to close
this bug as CANTFIX (because we really cannot fix it).

Note You need to log in before you can comment on or make changes to this bug.