Bug 440115 - Documentation needs to emphasize CLVM requirement for RHEL4 cluster
Documentation needs to emphasize CLVM requirement for RHEL4 cluster
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: Documentation (Show other bugs)
4.6
All Linux
low Severity low
: rc
: ---
Assigned To: Ryan Lerch
Content Services Development
: Documentation
Depends On:
Blocks: 440133 449834
  Show dependency treegraph
 
Reported: 2008-04-01 15:14 EDT by Steven J. Levine
Modified: 2009-08-19 23:29 EDT (History)
2 users (show)

See Also:
Fixed In Version: web
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-22 18:21:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven J. Levine 2008-04-01 15:14:03 EDT
Description of problem:
Customers are confused by LVM behavior when they try to use LVM on a RHEL4
cluster. Using LVM in a cluster requires CLVM (or HA-LVM).

This requirement needs to be noted throughout the documentation in all relevant
locations.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Steven J. Levine 2008-05-21 14:47:37 EDT
I sent the following proposal on 5-21-08 to Nick and Rob:

To address Bugs 440115, 440134, and 440133 (Documentation needs to emphasize
CLVM requirement for RHEL4 cluster), I plan to make the following updates to the
Red Hat cluster documentation for the RHEL 4.x and RHEL 5.x documentation. This
doesn't address the packaging question or the question of getting the warning to
customers in a more prominent place than within the documentation, but it's the
piece that we can provide within the documentation itself.

Please let me know if you have any questions or comments.

1. The LVM manual (all relevant releases)

a) I will add the following note to the section of the Introduction that
summarizes running LVM in a cluster (and mentions the clvmd daemon):

NOTE: Shared storage for use in Red Hat Cluster Suite requires that you be
running the cluster logical volume manager daemon (clvmd) or the High
Availability Logical Volume Management agents (HA-LVM). If you are not able to
use either the clvmd daemon or HA-LVM for operational reasons or because you do
not have the correct entitlements, you must not use single-instance LVM on the
shared disk as this may result in data corruption. If you have any concerns
please contact your Red Hat service representative.

b) The LVM Administrative Overview chapter includes a subsection on "Creating
LVM Volumes in a Cluster". I will add the same full note to that section.

c) In the section describing all the LVM commands, I will add this note right
after the first paragraph summarizing the chapter:

NOTE: If you are creating or modifying an LVM volume for a clustered
environment, you must ensure that you are running the clvmd daemon. For
information, see "Creating LVM Volumes in a Cluster".

2. Red Hat Cluster Suite Overview (both RHEL 4 and RHEL 5)

a) Section 1.6 of the Red Hat Cluster Suite Overview is a section on "Cluster
Logical Volume Manager". After the first introductory paragraph, I will add the
full note on shared storage.

b) Right at the beginning of the Cluster Suite Overview, in the Introduction,
there is a one-sentence summary of CLVM. I will add this note to that summary:

NOTE: When you create or modify a CLVM volume for a clustered environment, you
must ensure that you are running the clvmd daemon. For information, see "Cluster
Logical Volume Manager".

3.Configuring and Managing a Red Hat Cluster (both RHEL 4 and RHEL 5)

a) In the chapter on configuring Red Hat Cluster with Conga, there is a brief
subsection on "Configuring Cluster Storage". It refers to the LVM  manual for
all CLVM information. I will add the full warning note about running the clvmd
daemon.

b) In the chapter on configuring Red Hat Cluster with system-config-cluster,
there is a section on "Starting the Cluster Software". This already includes a
step on starting clvmd if there are clustered volumes. I think we can also add
the full note about running CLVMD or HA-LVM right here.

This would bring up the issue with running clvmd at every instance of CLVM
documentation.

-Steven
Comment 2 Steven J. Levine 2008-06-04 11:34:06 EDT
I made all the indicated changes for all versions of the documents and filed an
RT ticket to push the updated versions of the documents out to the documentation
websites:

https://engineering.redhat.com/rt3/Ticket/Display.html?id=24352


Note You need to log in before you can comment on or make changes to this bug.