Bug 440122 - Many packages listed twice, both as installed and uninstalled
Many packages listed twice, both as installed and uninstalled
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
: Reopened
: 439680 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-01 15:47 EDT by Deji Akingunola
Modified: 2008-04-07 01:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 01:11:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deji Akingunola 2008-04-01 15:47:14 EDT
Description of problem: I've noticed that gnome-packagekit lists some packages
twice, as installed and at the same time uninstalled (next to each other). For
example, in the 'Admin tools' group on my system right now, audit,
authconfig-gtk and yumex appear so.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Richard Hughes 2008-04-03 12:06:31 EDT
Fixed upstream in commit ed7fcb1a4a76e02717421b9f6b0dadc8d59a0882
Comment 2 Richard Hughes 2008-04-04 03:13:17 EDT
*** Bug 439680 has been marked as a duplicate of this bug. ***
Comment 3 Deji Akingunola 2008-04-04 10:14:38 EDT
I'm up2date on rawhide, and this bug is not fixed there yet, re-opening. 
Comment 4 Jeremy West 2008-04-06 00:41:45 EDT
I'm seeing the same results as well.  This is a *very* annoying bug for those of
us actually trying to use the new package tool
Comment 5 Matthias Clasen 2008-04-06 10:54:02 EDT
Fix is in rawhide now. No more duplicate installed/uninstalled packages.

I'm still seeing multiple listings of the same uninstalled package, if it is
provided by multiple repositories
Comment 6 Deji Akingunola 2008-04-07 01:11:28 EDT
(In reply to comment #5)
> Fix is in rawhide now. No more duplicate installed/uninstalled packages.
> 
Thanks Matthias, I can close this bug then.

> I'm still seeing multiple listings of the same uninstalled package, if it is
> provided by multiple repositories
IMHO, I prefer to think of this as a feature; it might actually be a good thing
to differentiate between same package from different repos, as one might have
enabled a feature which is not in the other, and the user can then make a choice.

Note You need to log in before you can comment on or make changes to this bug.