Bug 440153 - ipa-server-install no longer created named.conf when it's setting up bind
ipa-server-install no longer created named.conf when it's setting up bind
Status: CLOSED ERRATA
Product: freeIPA
Classification: Community
Component: ipa-server (Show other bugs)
unspecified
All Linux
high Severity high
: ---
: ---
Assigned To: Rob Crittenden
Chandrasekar Kannan
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-01 18:17 EDT by Michael Gregg
Modified: 2015-01-04 18:31 EST (History)
1 user (show)

See Also:
Fixed In Version: freeipa-2.0.0-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-27 03:14:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file with successful named.conf creation. (70.86 KB, text/plain)
2008-04-03 13:22 EDT, Michael Gregg
no flags Details

  None (edit)
Description Michael Gregg 2008-04-01 18:17:18 EDT
Description of problem:
running:
/usr/sbin/ipa-server-install -U --setup-bind -r <domain> <other options needed
for install> 
/etc/named.conf does not get created

How reproducible:
always

Steps to Reproduce:
1. install ipa server rpms
2. run /usr/sbin/ipa-server-install -U --hostname=ipaqavm.dsqa.sjc2.redhat.com
-r DSQA.SJC2.REDHAT.COM -p Secret123 -P Secret123 -a Secret123 --setup-bind -u
admin -d
3.
  
Actual results:
no /etc/named.conf file gets created.

Expected results:
the named.conf template to get copied to /etc/named.conf, and have relevant
fields changed.

Additional:
This is blocking on daily QA.
Comment 1 Rob Crittenden 2008-04-03 11:24:21 EDT
Committed in changeset 765
Comment 2 Michael Gregg 2008-04-03 13:21:19 EDT
verified good with build from 4-3-08

relevant section:
+ mv /etc/resolv.conf /etc/resolv.conf-old
+ echo 'nameserver 127.0.0.1'
+ '[' '!' -f /etc/named.conf ']'
+ sed -i 's/dump-file/forwarders { 10.14.63.2; }; dump-file/g' /etc/named.conf
+ /etc/init.d/named restart
Stopping named: .[  OK  ]
Starting named: [  OK  ]
+ grep named

From log file:
http://apoc.dsdev.sjc.redhat.com/tet/results/2008-04-03_06_43/IPA-server-log.txt
Comment 3 Michael Gregg 2008-04-03 13:22:31 EDT
Created attachment 300286 [details]
log file with successful named.conf creation.

log file with successful named.conf creation.
Comment 4 Michael Gregg 2008-04-16 13:09:46 EDT
As of nightly build from 4-16-08, named.conf again does not get created by
ipa-server-install

Here is the log, note the "setup-bind" in the options log.
Log from
http://apoc.dsdev.sjc.redhat.com/tet/results/2008-04-16_09_57/IPA-server-log.txt

+ /usr/sbin/ipa-server-install -U --hostname=iparhel5-64vm.dsqa.sjc2.redhat.com
-r DSQA.SJC2.REDHAT.COM -p Secret123 -P Secret123 -a Secret123 --setup-bind -u
admin -d
root        : DEBUG    Loading Index file from
'/var/lib/ipa/sysrestore/sysrestore.index'
root        : DEBUG    Loading StateFile from
'/var/lib/ipa/sysrestore/sysrestore.state'
root        : DEBUG    Loading Index file from
'/var/lib/ipa/sysrestore/sysrestore.index'
root        : ERROR    The IPA Server hostanme cannot resolve to localhost
(127.0.0.1), a routable IP address must be used.


The log file for this installation can be found in /var/log/ipaserver-install.log
==============================================================================
This program will setup the FreeIPA Server.

This includes:
  * Configure the Network Time Daemon (ntpd)
  * Create and configure an instance of Directory Server
  * Create and configure a Kerberos Key Distribution Center (KDC)
  * Configure Apache (httpd)
  * Configure TurboGears

To accept the default shown in brackets, press the Enter key.
Comment 5 Chandrasekar Kannan 2008-04-16 13:27:40 EDT
I just did a inter-active install and it worked ok. 

[root@ipaqa01 ~]# ipa-server-install --setup-bind

The log file for this installation can be found in /var/log/ipaserver-install.log
==============================================================================
This program will setup the FreeIPA Server.

This includes:
  * Configure the Network Time Daemon (ntpd)
  * Create and configure an instance of Directory Server
  * Create and configure a Kerberos Key Distribution Center (KDC)
  * Configure Apache (httpd)
  * Configure TurboGears

To accept the default shown in brackets, press the Enter key.

Enter the fully qualified domain name of the computer
on which you're setting up server software. Using the form
<hostname>.<domainname>
Example: master.example.com.


Server host name [ipaqa01.dsqa.sjc2.redhat.com]: 

The domain name has been calculated based on the host name.

Please confirm the domain name [dsqa.sjc2.redhat.com]: 

The IPA Master Server will be configured with
Hostname:    ipaqa01.dsqa.sjc2.redhat.com
IP address:  10.14.0.115
Domain name: dsqa.sjc2.redhat.com

The server must run as a specific user in a specific group.
It is strongly recommended that this user should have no privileges
on the computer (i.e. a non-root user).  The setup procedure
will give this user/group some permissions in specific paths/files
to perform server-specific operations.

The kerberos protocol requires a Realm name to be defined.
This is typically the domain name converted to uppercase.

Please provide a realm name [DSQA.SJC2.REDHAT.COM]: 

Certain directory server operations require an administrative user.
This user is referred to as the Directory Manager and has full access
to the Directory for system management tasks and will be added to the
instance of directory server created for IPA.
The password must be at least 8 characters long.

Directory Manager password: 
Password (confirm): 

The IPA server requires an administrative user, named 'admin'.
This user is a regular system account used for IPA server administration.

IPA admin password: 
Password (confirm): 


The following operations may take some minutes to complete.
Please wait until the prompt is returned.
Configuring ntpd
  [1/4]: stopping ntpd
  [2/4]: writing configuration
  [3/4]: configuring ntpd to start on boot
  [4/4]: starting ntpd
done configuring ntpd.
Configuring directory server:
  [1/16]: creating directory server user
  [2/16]: creating directory server instance
  [3/16]: adding default schema
  [4/16]: enabling memberof plugin
  [5/16]: enabling referential integrity plugin
  [6/16]: enabling distributed numeric assignment plugin
  [7/16]: configuring uniqueness plugin
  [8/16]: creating indices
  [9/16]: configuring ssl for ds instance
  [10/16]: configuring certmap.conf
  [11/16]: restarting directory server
  [12/16]: adding default layout
  [13/16]: configuring Posix uid/gid generation as first master
  [14/16]: adding master entry as first master
  [15/16]: initializing group membership
  [16/16]: configuring directory to start on boot
done configuring dirsrv.
Configuring Kerberos KDC
  [1/13]: setting KDC account password
  [2/13]: adding sasl mappings to the directory
  [3/13]: adding kerberos entries to the DS
  [4/13]: adding default ACIs
  [5/13]: configuring KDC
  [6/13]: adding default keytypes
  [7/13]: creating a keytab for the directory
  [8/13]: creating a keytab for the machine
  [9/13]: exporting the kadmin keytab
  [10/13]: adding the password extension to the directory
  [11/13]: adding the kerberos master key to the directory
  [12/13]: starting the KDC
  [13/13]: configuring KDC to start on boot
done configuring krb5kdc.
Configuring ipa_kpasswd
  [1/2]: starting ipa_kpasswd 
  [2/2]: configuring ipa_kpasswd to start on boot
done configuring ipa_kpasswd.
Configuring the web interface
  [1/10]: disabling mod_ssl in httpd
  [2/10]: Setting mod_nss port to 443
  [3/10]: Adding URL rewriting rules
  [4/10]: configuring httpd
  [5/10]: creating a keytab for httpd
  [6/10]: Setting up ssl
  [7/10]: Setting up browser autoconfig
  [8/10]: configuring SELinux for httpd
  [9/10]: restarting httpd
  [10/10]: configuring httpd to start on boot
done configuring httpd.
Configuring ipa_webgui
  [1/2]: starting ipa_webgui 
  [2/2]: configuring ipa_webgui to start on boot
done configuring ipa_webgui.
This program is about to replace the DNS Server configuration,
with an automatically generated one, based on the data gathered so far.
This will REPLACE any existing configuration.
Are you sure you want to configure the DNS Server ? [no]: yes
Configuring bind:
  [1/5]: Setting up our zone
  [2/5]: Setting up named.conf
  [3/5]: restarting named
named service failed to start
  [4/5]: configuring named to start on boot
  [5/5]: Changing resolve.conf to point to ourselves
done configuring named.
restarting the directory server
restarting the KDC
==============================================================================
Setup complete

Next steps:
        1. You may need to open some network ports - specifically:
                TCP Ports:
                  * 80, 443: HTTP/HTTPS
                  * 389, 636: LDAP/LDAPS
                  * 88, 464: kerberos
                UDP Ports:
                  * 88, 464: kerberos
                  * 123: ntp

        2. You can now obtain a kerberos ticket using the command: 'kinit admin'
           This ticket will allow you to use the IPA tools (e.g., ipa-adduser)
           and the web user interface.

Be sure to back up the CA certificate stored in
/etc/dirsrv/slapd-DSQA-SJC2-REDHAT-COM/cacert.p12
The password for this file is in /etc/dirsrv/slapd-DSQA-SJC2-REDHAT-COM/pwdfile.txt
[root@ipaqa01 ~]# 
Comment 6 Michael Gregg 2008-04-16 13:32:13 EDT
So maybe the description of the bug needs to change, or this is a new bug. 

Running a unattended install seems to hit this problem.

 
Comment 7 Michael Gregg 2008-04-16 18:37:49 EDT
My perception of the error was wrong. ipa-server-install was failing due to a
hosts file configuration problem. 

Moved this problem to bug #442812

Note You need to log in before you can comment on or make changes to this bug.