Bug 440181 - Displays wrong color w/ PostScript files (yellow background)
Displays wrong color w/ PostScript files (yellow background)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
rawhide
powerpc Linux
low Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-01 23:01 EDT by Benjamin Jacobs
Modified: 2008-08-11 18:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-11 18:58:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin Jacobs 2008-04-01 23:01:55 EDT
Description of problem:
When viewing any (e)ps file with evince, the background color is always
displayed as yellow, instead of white. gv (ghostview) doesn't exhibit this
problem and shows the right white background. I believe that this mis-behaviour
is fairly recent (~ <3 weeks from now).

After a more bit more analysis, it appears that the blue component of the color
is ignored. I crafted a simple image with 3 simple colors:
 red shows as red (ff0000)
 green shows as green (00ff00)
 but blue shows as black (000000)
 and white as yellow (ffff00)

Looks like an endian issue to me since I'm on ppc. Thanks for looking into it :)

Workarround: Convert those files to pdf with ps2pdf (or epstopdf) and evince
will display the correct colors.

Version-Release number of selected component (if applicable):
poppler-0.8.0-1.fc9.ppc
poppler-glib-0.8.0-1.fc9.ppc
evince-2.22.0-3.fc9.ppc
Comment 1 Bug Zapper 2008-05-14 04:33:37 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Benjamin Jacobs 2008-07-08 19:27:04 EDT
gnome bugzilla entry: http://bugzilla.gnome.org/show_bug.cgi?id=540950
Comment 3 Benjamin Jacobs 2008-08-11 18:01:52 EDT
Hi,

I can confirm that the current libspectre and evince in rawhide fix the issue.

Note You need to log in before you can comment on or make changes to this bug.