Bug 440184 - GTK-VNC renders ontop of all windows
GTK-VNC renders ontop of all windows
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk-vnc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-02 00:47 EDT by Andrew Bartlett
Modified: 2008-04-03 15:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 15:59:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix rendering artifacts & badmatch (2.96 KB, patch)
2008-04-03 15:25 EDT, Daniel Berrange
no flags Details | Diff

  None (edit)
Description Andrew Bartlett 2008-04-02 00:47:05 EDT
Description of problem:
Every time the VM guest updates it's screen, the GUI portion (ie, not the
borders) is pushed to the top of the display.

Version-Release number of selected component (if applicable):
libvirt-0.4.1-6.fc9.i386
gtk-vnc-0.3.4-1.fc9.i386
virt-manager-0.5.4-2.fc9.i386

How reproducible:
Every time

Steps to Reproduce:
1. Start VM from virt-manager
2. Place another window in foreground
3. Wait (not long) until the guest updates it's window
  
Actual results:
Guest VM portion of window flickers forwerd

Expected results:
Window remains hidden as expected

Additional info:
Very frustrating
Comment 1 Daniel Berrange 2008-04-02 07:49:57 EDT
Can you tell me what Xorg video driver you have ?
Comment 2 Andrew Bartlett 2008-04-03 04:36:50 EDT
intel
Comment 3 Daniel Berrange 2008-04-03 14:16:39 EDT
Turns out this is a bug in GTK-VNC. It is failing to set the z-buffer depth, so
its rendering to the top stack....over every window :-) 
Comment 4 Daniel Berrange 2008-04-03 15:25:25 EDT
Created attachment 300314 [details]
Fix rendering artifacts & badmatch
Comment 5 Daniel Berrange 2008-04-03 15:59:51 EDT
Built into gtk-vnc-0.3.4-3.fc9

Note You need to log in before you can comment on or make changes to this bug.