Bug 440232 - [RHEL5.2] evolution-data-server-1.12 crashes on malformed CalDAV calendar URL
Summary: [RHEL5.2] evolution-data-server-1.12 crashes on malformed CalDAV calendar URL
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution-data-server   
(Show other bugs)
Version: 5.2
Hardware: All Linux
low
low
Target Milestone: rc
: ---
Assignee: Milan Crha
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-02 13:03 UTC by Chris Runge
Modified: 2009-09-02 09:14 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 09:14:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace (10.07 KB, text/plain)
2008-04-02 13:03 UTC, Chris Runge
no flags Details
Backtrace with debuginfo (9.63 KB, text/plain)
2008-04-02 19:44 UTC, Chris Runge
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1259 normal SHIPPED_LIVE evolution-data-server bug fix update 2009-09-01 09:12:26 UTC
GNOME Bugzilla 566627 None None None Never

Description Chris Runge 2008-04-02 13:03:31 UTC
Description of problem:

Periodically starting and using Evolution in RHEL 5.2 beta generates backtraces
in evolution-data-server-1.12. Evolution does _not_ crash but the backtraces are
annoying.

Version-Release number of selected component (if applicable):

rpm -qa | grep evolution
evolution-2.12.3-8.el5
evolution-data-server-1.12.3-6.el5
evolution-data-server-devel-1.12.3-6.el5
evolution-connector-2.12.3-4.el5
evolution-webcal-2.7.1-6

How reproducible:

Occurs frequently when starting and using Evolution in 5.2 beta, although no
known steps to reliably reproduce.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

attaching generated backtrace

Comment 1 Chris Runge 2008-04-02 13:03:31 UTC
Created attachment 300058 [details]
backtrace

Comment 2 Matthew Barnes 2008-04-02 17:33:23 UTC
Can you please install the following debuginfo packages and submit a new
backtrace?  Thanks.

   evolution-data-server-debuginfo
   glib2-debuginfo

Comment 3 Chris Runge 2008-04-02 18:10:19 UTC
sure... where do I get the debuginfo packages?

Comment 4 Matthew Barnes 2008-04-02 18:53:50 UTC
I believe there's an RHN channel for them, but I'm never been real clear to me.
 If you're behind the VPN, I usually just grab them from brewroot.

http://porkchop.redhat.com/brewroot/packages/evolution-data-server/1.12.3/6.el5/
http://porkchop.redhat.com/brewroot/packages/glib2/2.12.3/2.fc6/

(Make sure these links agree with the package versions you have installed.)

Comment 5 Chris Runge 2008-04-02 19:44:20 UTC
Created attachment 300128 [details]
Backtrace with debuginfo

Comment 6 Chris Runge 2008-04-02 19:45:29 UTC
Note: backtrace occurs with regularity when starting Evolution the first time
for a new login session. Exiting and restarting Evolution without logging
out/logging in again does not appear to cause the problem as much/at all.

Comment 7 Matthew Barnes 2008-04-02 19:57:48 UTC
The new backtrace looks good.  Thanks.

Evolution appears to be dying in its CalDAV module.

Comment 8 Chris Runge 2008-04-02 20:54:44 UTC
That sounds right; I just received another backtrace when someone sent me a
calendar invite.

Comment 10 Matthew Barnes 2008-06-17 18:32:52 UTC
Chris, could you possibly attach a calendar invite here that causes the crash
for you, so we can try to reproduce it for ourselves?

Comment 11 Chris Runge 2008-06-17 21:30:01 UTC
Unfortunately I no longer have access to a system with this software installed.

Comment 12 RHEL Product and Program Management 2008-07-21 23:04:06 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 14 Milan Crha 2008-08-29 16:10:43 UTC
(In reply to comment #11)
> Unfortunately I no longer have access to a system with this software installed.

Ouch, the data seems to be crucial for this report to be fixed properly.

Comment 15 Milan Crha 2009-02-10 14:04:05 UTC
I reinvestigated and based on the source lines, it seems your uri in a CalDAV preferences was broken, thus the soup_message_new returned NULL.
This had been fixed recently, in bug #477815. We can backport that fix.

Comment 21 Tomas Hoger 2009-08-26 12:03:13 UTC
(In reply to comment #3)
> sure... where do I get the debuginfo packages?  

For posterity, you can grab debuginfo packages from RHN or public FTP server.

Máirín has a redirector to proper FTP directory:
  http://people.redhat.com/duffy/debuginfo/

On RHEL5, you should be able to fetch them from public FTP using:
  yum install foo-debuginfo --enablerepo rhel-debuginfo

Comment 22 errata-xmlrpc 2009-09-02 09:14:54 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1259.html


Note You need to log in before you can comment on or make changes to this bug.