Bug 44024 - rc.sysinit: maybe add '-s buf' to 'dmesg > /var/log/dmesg'
Summary: rc.sysinit: maybe add '-s buf' to 'dmesg > /var/log/dmesg'
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-09 11:38 UTC by giulioo
Modified: 2014-03-17 02:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-09 11:39:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description giulioo 2001-06-09 11:38:56 UTC
Description of problem:
AFAIK dmesg defaults to a small buffer. Since you increase the LOG_BUF_LEN 
in kernel, it may be good to use
dmesg -s <big_buf> > /var/log/dmesg
in rc.sysinit (I think big_buf should be >= 65536)

How reproducible/Steps to Reproduce:
On this system I haven't any driver that can trigger the problem, so I 
just tried to fill the dmesg buffer after boot to confirm that dmesg still 
needs '-s <buf>' to get all the available info.

Additional info:
I have this problem on a rh6x system with 8 software raid1 partitions and 
applied the fix suggested above.

Comment 1 Bill Nottingham 2001-08-07 06:50:41 UTC
Will be fixed in 6.12-1.


Note You need to log in before you can comment on or make changes to this bug.