Bug 440288 - Red Hat Cert fails on USB Storage
Red Hat Cert fails on USB Storage
Status: CLOSED NOTABUG
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
other All
low Severity medium
: ---
: ---
Assigned To: YangKun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-02 12:56 EDT by IBM Bug Proxy
Modified: 2008-07-16 17:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-29 01:58:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sosreport (355.43 KB, application/octet-stream)
2008-04-02 12:56 EDT, IBM Bug Proxy
no flags Details
HTS PLan (1.50 KB, text/xml)
2008-04-02 12:56 EDT, IBM Bug Proxy
no flags Details
HTS Results (176.28 KB, text/xml)
2008-04-08 13:08 EDT, IBM Bug Proxy
no flags Details
4/16 Run HTS Results (268.60 KB, text/xml)
2008-04-16 07:41 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 43718 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-04-02 12:56:26 EDT
---Problem Description---
Ran the latest Red Hat Hardware Cert package(obtained from
http://people.redhat.com/ltroan/fixes/hts/test/) on Cell QS22 Blade and it
failed the storage test for on board USB flash drive.  QS22 Blades are diskless
systems, but an optional component is an 8G on oboard USB flash drive .  This
was ran on a RHEL5.2 Snapshot 2 Release.  This machine was booted via NFSroot
and no modifications were made relevant to the USB flash drive. 

Test Run 1
----------------------------------------------------------------
usb                                                  - PASS
network eth1    net_00_1a_64_0f_02_15                - PASS
network eth0    net_00_1a_64_0f_02_14                - PASS
memory                                               - PASS
storage sda     storage_serial_STEC_8GB_USB_STI_m92  - FAIL
core                                                 - PASS
info                                                 - PASS

Combined Results for 1 Runs:
--------------------------------------------
   7 tests planned
   7 tests run
   1 tests always failed
   6 tests always passed

---uname output---
2.6.18-86.el5
 
Machine Type = Cell Blade QS22 
 
---Steps to Reproduce---
run:
hts --test network certify --server lewis7
Comment 1 IBM Bug Proxy 2008-04-02 12:56:30 EDT
Created attachment 300094 [details]
sosreport
Comment 2 IBM Bug Proxy 2008-04-02 12:56:32 EDT
Created attachment 300095 [details]
HTS PLan
Comment 3 Greg Nichols 2008-04-03 10:14:01 EDT
please attach the results showing the storage test failure, typically in
/var/hts/results.xml.

Comment 4 IBM Bug Proxy 2008-04-08 13:08:53 EDT
Created attachment 301661 [details]
HTS Results

Attaching results.xml file as requested.
Comment 5 Greg Nichols 2008-04-09 10:18:34 EDT
The error is: 

Error: sda has active filesystems on it.
It cannot be tested. You may need to reinstall.
...finished running ./storage.py, exit code=1

Comment 6 YangKun 2008-04-10 02:36:10 EDT
so this is a diskless system and was booted through network ?

turns out there's no swap partition on /dev/sda and it's in use by the system:
+---------- /proc/mounts ----------+
/dev/sda /tmp/hts-storage-pEKttF/mnt/tests/HTS/hts/storage/sda.Cf3442 ext3
rw,data=ordered 0 0
------------------------------------

this may because of an un-finished run of the storage test before(causing the
/dev/sda still been mounted).

Could you please try to un-mount it first, or create a swap partition on
/dev/sda and then re-run the storage test ?

Thanks
-YK
Comment 7 IBM Bug Proxy 2008-04-10 11:07:06 EDT
------- Comment From lxie@us.ibm.com 2008-04-10 10:54 EDT-------
(In reply to comment #12)
> ------- Comment From ykun@redhat.com 2008-04-10 02:36 EST-------
> so this is a diskless system and was booted through network ?
>
> turns out there's no swap partition on /dev/sda and it's in use by the system:
> +---------- /proc/mounts ----------+
> /dev/sda /tmp/hts-storage-pEKttF/mnt/tests/HTS/hts/storage/sda.Cf3442 ext3
> rw,data=ordered 0 0
> ------------------------------------
>
> this may because of an un-finished run of the storage test before(causing the
> /dev/sda still been mounted).
>
> Could you please try to un-mount it first, or create a swap partition on
> /dev/sda and then re-run the storage test ?
>
> Thanks
> -YK

Abe,

Can you try what RH suggested?
Comment 8 IBM Bug Proxy 2008-04-16 07:40:58 EDT
------- Comment From abareval@us.ibm.com 2008-04-16 07:32 EDT-------
Hello,
I attempted hts run on RHEL5.2 Snap4 and while it did pass on USB on board
device, it failed on SAS Device.  The SAS Device DID have swap space allocated.

Test Run 1
----------------------------------------------------------------
usb                                                  - PASS
network eth1    net_00_1a_64_0f_02_15                - PASS
network eth0    net_00_1a_64_0f_02_14                - PASS
memory                                               - PASS
storage sda     storage_serial_STEC_8GB_USB_STI_m92  - PASS
storage sdb     storage_serial_3600a0b8000387eca000002ad47fc0f19 - FAIL
core                                                 - PASS
info                                                 - PASS

Combined Results for 1 Runs:
--------------------------------------------
8 tests planned
8 tests run
1 tests always failed
7 tests always passed

------- Comment From abareval@us.ibm.com 2008-04-16 07:36 EDT-------
(In reply to comment #15)
> Hello,
> I attempted hts run on RHEL5.2 Snap4 and while it did pass on USB on board
> device, it failed on SAS Device.  The SAS Device DID have swap space
allocated.
> Test Run 1
> ----------------------------------------------------------------
> usb                                                  - PASS
> network eth1    net_00_1a_64_0f_02_15                - PASS
> network eth0    net_00_1a_64_0f_02_14                - PASS
> memory                                               - PASS
> storage sda     storage_serial_STEC_8GB_USB_STI_m92  - PASS
> storage sdb     storage_serial_3600a0b8000387eca000002ad47fc0f19 - FAIL
> core                                                 - PASS
> info                                                 - PASS
> Combined Results for 1 Runs:
> --------------------------------------------
>    8 tests planned
>    8 tests run
>    1 tests always failed
>    7 tests always passed

Note that this was booted up through the network, on QS22-2
Comment 9 IBM Bug Proxy 2008-04-16 07:41:01 EDT
Created attachment 302582 [details]
4/16 Run HTS Results

HTS REsults from run showing failure on SAS Device
Comment 10 YangKun 2008-04-16 22:53:24 EDT
the error is: 
-----------------------------------------------
Error: sdb is currently in use by LVM. 
It cannot be tested. You may need to reinstall.
...finished running ./storage.py, exit code=1
-----------------------------------------------


disk partions on sdb are:
---------------------------------------------------------------------
/dev/sdb1   *           1           1        8001   41  PPC PReP Boot
/dev/sdb2               2          14      104422+  83  Linux
/dev/sdb3              15        2610    20852370   8e  Linux LVM
---------------------------------------------------------------------
I guess there should be a swap in the LVM, could you please provide the file
"/etc/fstab" ?


log shows there's no swap partitions are active:
---------------------------------------------------
+---------- /proc/swaps ----------+

---------------------------------------------------
could you please verify you can see all swap partitions shown in "/proc/swaps"
before you run the storage test ?


besides, seems the root filesystem "/" was mounted through nfs:
--------------------------------------------------------------
+---------- /proc/mounts ----------+
rootfs / rootfs rw 0 0
192.168.21.1:/srv/diskless/qs22-2 / nfs
rw,vers=3,rsize=32768,wsize=32768,hard,nolock,proto=udp,timeo=7,retrans=3,sec=sys,addr=192.168.21.1
0 0
--------------------------------------------------------------
what's the purpose of testing the network storage ?

-YK
Comment 11 IBM Bug Proxy 2008-04-22 12:01:15 EDT
------- Comment From abareval@us.ibm.com 2008-04-22 11:56 EDT-------
(In reply to comment #18)
>
>
> disk partions on sdb are:
> ---------------------------------------------------------------------
> /dev/sdb1   *           1           1        8001   41  PPC PReP Boot
> /dev/sdb2               2          14      104422+  83  Linux
> /dev/sdb3              15        2610    20852370   8e  Linux LVM
> ---------------------------------------------------------------------
> I guess there should be a swap in the LVM, could you please provide the file
> "/etc/fstab" ?
>

[root@qs22-2 ~]# cat /etc/fstab
/dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
spufs                   /spu                    spufs   defaults        0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0

*Note: The /etc/fstab above is from the OS on the SAS Storage(so I had to reboot
into that OS).  The test was ran on the OS provided on NFSroot storage.  The
releases are the same for both.

> what's the purpose of testing the network storage ?

That's right, this test was ran on an NFSroot mounted filesystem.   I simply ran
the hts certify and it ran the SAS storage test by default.
Comment 12 YangKun 2008-04-25 05:29:28 EDT
(In reply to comment #11)
> ------- Comment From abareval@us.ibm.com 2008-04-22 11:56 EDT-------
> (In reply to comment #18)
> >
> >
> > disk partions on sdb are:
> > ---------------------------------------------------------------------
> > /dev/sdb1   *           1           1        8001   41  PPC PReP Boot
> > /dev/sdb2               2          14      104422+  83  Linux
> > /dev/sdb3              15        2610    20852370   8e  Linux LVM
> > ---------------------------------------------------------------------
> > I guess there should be a swap in the LVM, could you please provide the file
> > "/etc/fstab" ?
> >
> 
> [root@qs22-2 ~]# cat /etc/fstab
> /dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
> LABEL=/boot             /boot                   ext3    defaults        1 2
> spufs                   /spu                    spufs   defaults        0 0
> tmpfs                   /dev/shm                tmpfs   defaults        0 0
> devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
> sysfs                   /sys                    sysfs   defaults        0 0
> proc                    /proc                   proc    defaults        0 0
> /dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0
> 
> *Note: The /etc/fstab above is from the OS on the SAS Storage(so I had to reboot
> into that OS).  The test was ran on the OS provided on NFSroot storage.  The
> releases are the same for both.

there is a swap partition in the system, but seems it's not active. could  you
please use "mkswap" and "swapon" to "activate" it first, could you please try to
run the storage test again when you do see this swap in /proc/swaps ?

> 
> > what's the purpose of testing the network storage ?
> 
> That's right, this test was ran on an NFSroot mounted filesystem.   I simply ran
> the hts certify and it ran the SAS storage test by default.

please notice that if there's no storage-related options for this machine, then
we'll not list any storage items in the testplan. You can just disable it using
the "--disable" option, please refer to "hts --help" or the HTS user guide.

Thanks
-YK
Comment 13 IBM Bug Proxy 2008-04-28 16:17:17 EDT
------- Comment From abareval@us.ibm.com 2008-04-28 16:15 EDT-------
(In reply to comment #20)
> ------- Comment From ykun@redhat.com 2008-04-25 05:29 EST-------
> (In reply to comment #11)
> > ------- Comment From abareval@us.ibm.com 2008-04-22 11:56 EDT-------
> > (In reply to comment #18)
> > >
> > >
> > > disk partions on sdb are:
> > > ---------------------------------------------------------------------
> > > /dev/sdb1   *           1           1        8001   41  PPC PReP Boot
> > > /dev/sdb2               2          14      104422+  83  Linux
> > > /dev/sdb3              15        2610    20852370   8e  Linux LVM
> > > ---------------------------------------------------------------------
> > > I guess there should be a swap in the LVM, could you please provide the file
> > > "/etc/fstab" ?
> > >
> >
> > [root@qs22-2 ~]# cat /etc/fstab
> > /dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
> > LABEL=/boot             /boot                   ext3    defaults        1 2
> > spufs                   /spu                    spufs   defaults        0 0
> > tmpfs                   /dev/shm                tmpfs   defaults        0 0
> > devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
> > sysfs                   /sys                    sysfs   defaults        0 0
> > proc                    /proc                   proc    defaults        0 0
> > /dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0
> >
> > *Note: The /etc/fstab above is from the OS on the SAS Storage(so I had to reboot
> > into that OS).  The test was ran on the OS provided on NFSroot storage.  The
> > releases are the same for both.
>
> there is a swap partition in the system, but seems it's not active. could  you
> please use "mkswap" and "swapon" to "activate" it first, could you please try to
> run the storage test again when you do see this swap in /proc/swaps ?
>
> >
> > > what's the purpose of testing the network storage ?
> >
> > That's right, this test was ran on an NFSroot mounted filesystem.   I simply ran
> > the hts certify and it ran the SAS storage test by default.
>
> please notice that if there's no storage-related options for this machine, then
> we'll not list any storage items in the testplan. You can just disable it using
> the "--disable" option, please refer to "hts --help" or the HTS user guide.
>
> Thanks
> -YK

Hello,
I've ran the latest hts on Snap6 on a QS22 that had no storage, and it passed.
With that being said, since storage will not be part of the plan, the matter is
now resolved.  Will reject Bug

Note You need to log in before you can comment on or make changes to this bug.