Bug 440290 - avc: denied { getattr } for comm="pam_console_app" path="/dev/scd0" dev=tmpfs
avc: denied { getattr } for comm="pam_console_app" path="/dev/scd0" dev=tmpfs
Status: CLOSED DUPLICATE of bug 441054
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy-targeted (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Daniel Walsh
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-02 13:21 EDT by Milan Zazrivec
Modified: 2008-04-05 12:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-05 12:23:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Zazrivec 2008-04-02 13:21:03 EDT
Description of problem:
RHEL5.2-Server-20080402.nightly new installation produces avc denial
after reboot:
audit(1207136590.977:4): avc:  denied  { getattr } for  pid=2697
comm="pam_console_app" path="/dev/scd0" dev=tmpfs ino=17446
scontext=system_u:system_r:pam_console_t:s0-s0:c0.c1023
tcontext=system_u:object_r:device_t:s0 tclass=blk_file

Version-Release number of selected component (if applicable):
RHEL5.2-Server-20080402.nightly / selinux-policy-targeted-2.4.6-126.el5
Comment 2 Milan Zazrivec 2008-04-02 14:31:42 EDT
Mentioned problem was not present in RHEL5.2-Server-20080401.nightly
Comment 5 Daniel Walsh 2008-04-04 16:19:52 EDT
SELinux has no idea what this device is /dev/scd0

It does not know what this is in rawhide either.

So this is not a regression of selinux it might be a regression in what is
suddenly creating a device named scd0.

This is usually a symbolic link to /dev/sr0 which would be labeled correctly.

So we can add a labeling for the device if it is supposed to be there but if
this was supposed to be a symbolic link then what ever created it is broken.

Comment 6 Milan Zazrivec 2008-04-05 12:23:29 EDT

*** This bug has been marked as a duplicate of 441054 ***

Note You need to log in before you can comment on or make changes to this bug.