Bug 440304 - vpnc binary depends on Perl
Summary: vpnc binary depends on Perl
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: vpnc   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-02 18:06 UTC by fed1bugs.noblesmith
Modified: 2008-04-03 08:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 08:42:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description fed1bugs.noblesmith 2008-04-02 18:06:32 UTC
All the recent versions of the vpnc binary package lists these as dependencies:

/usr/bin/perl
perl(IO::File)
perl(strict)
perl(warnings)

But it didn't actually install any Perl scripts. I looked at the source, and
*building* vpnc involves Perl, for debugging and for making the man
documentation. But it's never used outside of that. The dependency adds about 10
MB to what should be a really small package. (Ubuntu doesn't have the same
dependency.)

Comment 1 Tomas Mraz 2008-04-03 08:42:45 UTC
Fixed in vpnc-0.5.1-4.fc9 in rawhide.


Note You need to log in before you can comment on or make changes to this bug.