Bug 440323 - ftrace does not run the application
ftrace does not run the application
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: frysk (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Andrew Cagney
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-02 15:49 EDT by Daniel Berrange
Modified: 2008-04-07 13:55 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 13:55:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 6003 None None None Never

  None (edit)
Description Daniel Berrange 2008-04-02 15:49:51 EDT
Description of problem:
ftrace does not appear to work at all - it spews an error messages to stderr and
then sits around doing nothing

Version-Release number of selected component (if applicable):
frysk-0.0.1.2008.03.19.rh1-1.fc9.x86_64

How reproducible:
Always

Steps to Reproduce:
1. ftrace ls
2.
3.
  
Actual results:
#  ftrace -sys= ls
execvp: No such file or directory
<hang forver...>

Expected results:
A file listing & trace output

Additional info:
Comment 1 Daniel Berrange 2008-04-02 15:57:17 EDT
It appears that ftrace is failing to honour the $PATH, since giving an explicit
path works

# ftrace /bin/ls
5753.5753 attached /bin/ls
Comment 2 Mark Wielaard 2008-04-02 16:00:33 EDT
This is most likely upstream bug
http://sourceware.org/bugzilla/show_bug.cgi?id=6003 "ftrace does not follow
$PATH". for now try supplying the full path to the executable /bin/ls
Comment 3 Andrew Cagney 2008-04-07 13:55:37 EDT
I've fixed this.

Installed: frysk.i386 0:0.2.1-2.fc9
Complete!
cagney@tonsil$ ftrace ls
2382.2382 attached /bin/ls
a.out  Desktop  fedora       isa        ols-2007.pdf  share     Tmp2.bmp
bin    devel    foo.ps       loop.c     prefix        tmp
bugs   diffs    ieee-854.ps  nohup.out  ps3.anaconda  TMP1.BMP
2382.2382 exited with status 0

Note You need to log in before you can comment on or make changes to this bug.