This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 440329 - Newer release is available
Newer release is available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cegui (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-02 16:22 EDT by Alexey Torkhov
Modified: 2008-05-23 16:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-22 17:38:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch from spec to new cegui version (2.15 KB, patch)
2008-05-17 04:50 EDT, Alexey Torkhov
no flags Details | Diff
Updated patch for cegui to new version (7.79 KB, patch)
2008-05-17 04:52 EDT, Alexey Torkhov
no flags Details | Diff
Updated patch "userverso" for cegui to new version (892 bytes, patch)
2008-05-17 04:52 EDT, Alexey Torkhov
no flags Details | Diff
Updated patch "userverso" for cegui to new version (1.08 KB, text/x-patch)
2008-05-17 09:10 EDT, Alexey Torkhov
no flags Details

  None (edit)
Description Alexey Torkhov 2008-04-02 16:22:22 EDT
Newer version 0.6.0 of cegui is available:
http://www.cegui.org.uk/phpBB2/viewtopic.php?p=13973

Please update the package.
Comment 1 Alexey Torkhov 2008-05-17 04:50:58 EDT
Created attachment 305792 [details]
Patch from spec to new cegui version

As I needed new package, I decided to made it myself.
Comment 2 Alexey Torkhov 2008-05-17 04:52:13 EDT
Created attachment 305793 [details]
Updated patch for cegui to new version
Comment 3 Alexey Torkhov 2008-05-17 04:52:46 EDT
Created attachment 305794 [details]
Updated patch "userverso" for cegui to new version
Comment 4 Alexey Torkhov 2008-05-17 09:10:24 EDT
Created attachment 305801 [details]
Updated patch "userverso" for cegui to new version

Previous one wasn't working.
Comment 5 Hans de Goede 2008-05-18 03:38:03 EDT
Re-assigning to me as I'm the new owner of cegui, and looking into this.
Comment 6 Hans de Goede 2008-05-22 17:38:25 EDT
cegui-0.6.0 is now available in rawhide, unfortunately it breaks ABI
compatibility with earlier releases and therefor I cannot make this an update
for F-8 and F-9, esp. since cegui also is used by third party repositories (smc
from dribble uses it for example).
Comment 7 Alexey Torkhov 2008-05-23 01:05:26 EDT
I'm guessing it's the problem of third-party repos to update and recompile their
packages, isn't it? I think you should update it for F8 and F9.
More, if user have installed 3rd party software that uses cegui, yum would not
allow to update until there will be update for these software.

Anyway, thanks for update. I've installed rawhide package on F9 and it seems to
work fine.

P.S. If you are not updating ogre in F9/F8 for same reason, it applies to it too.
Comment 8 Hans de Goede 2008-05-23 02:48:08 EDT
(In reply to comment #7)
> I'm guessing it's the problem of third-party repos to update and recompile their
> packages, isn't it?

Not within a release, a release means that we promise ABI stability, users might
have compiled and installed software themselves breaking that by a simple yum
update is _not_ acceptable, unless there are very good reasons to do so.

Now if there was some new software you wanted to package that needs the new
version thats a good reason. Fedora is about shipping the latest and greatest at
the moment of release, not updating to the latest and greatest after release,
esp. not if that breaks the ABI.

> P.S. If you are not updating ogre in F9/F8 for same reason, it applies to it too.

Yes that is one of the mean reasons. I've discussed this in the past with the
ogre developers. The problem is that they cannot even keep their ABI stable for
a bugfix release (think 1.4.7 -> 1.4.8). Which really isn't that hard todo, but
it seems that ABI stability just does not have a priority.

The same goes for cegui, looking at the changes that cause the ABI breakage
between 0.5.0 and 0.6.0 most could have been avoided easily.
Comment 9 Alexey Torkhov 2008-05-23 12:59:06 EDT
(In reply to comment #8)
> Not within a release, a release means that we promise ABI stability
Well, then it's ok.

> Now if there was some new software you wanted to package that needs the new
> version thats a good reason.
That's exactly what I want to do. Though it have another requirement that need
to be included in repository.
Comment 10 Hans de Goede 2008-05-23 16:22:02 EDT
(In reply to comment #9)
> > Now if there was some new software you wanted to package that needs the new
> > version thats a good reason.
> That's exactly what I want to do. Though it have another requirement that need
> to be included in repository.

Give me a ping when the package needing the new cegui has passed review (and
thus is ready for inclusion) then I'll do an update for atleast F-9 of the whole
shebang, to give you an idea of the impact, this means rebuilding (and issueing
updates for):
cegui
crystalspace
ogre
chess
TnL
vegastrike

Note You need to log in before you can comment on or make changes to this bug.