This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 440341 - anaconda with 20080402 images does not work in a graphics mode
anaconda with 20080402 images does not work in a graphics mode
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-02 18:55 EDT by Michal Jaegermann
Modified: 2008-04-22 15:19 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 15:19:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2008-04-02 18:55:40 EDT
Description of problem:

An attempt to boot into installation in a graphics mode
ends up with a black screen and non-responsive keyboard the
moment when X server is supposed to be started.
RV280 [Radeon 9200 PRO] graphics card.  Is this a grotty
X server (I do not recall that beeing so bad ever) or this
is something anaconda specific?

Going into a rescue mode or starting an installation in a text
mode looks like working OK.

Version-Release number of selected component (if applicable):
20080402 boot images

How reproducible:
always
Comment 1 Jeremy Katz 2008-04-02 23:14:32 EDT
X was entirely hosed in today's rawhide and was discussed as such on multiple
lists on multiple occasoins.  Will be fixed tomorrow.
Comment 2 Michal Jaegermann 2008-04-06 20:06:32 EDT
AFAIK rawhide X is no longer hosed.  It surely works on the same
hardware I tried this test.  I did the same with 20080406 images
(anaconda identifies itself as 11.4.0.65) and results were as
described in the original report.  A blank screen and apparently a
dead keyboard (or maybe video crashed to such extent that even text
consoles are black).  A machine does respond to pings but I have
no way to log on it and look around.
Comment 3 Jeremy Katz 2008-04-07 10:01:21 EDT
The X fix didn't help the installer case (X was still SEGV'ing).  We've put in a
brute force hack to work around it that should be in today's rawhide.  Even
though it makes me cringe a bit.
Comment 4 Michal Jaegermann 2008-04-19 18:59:28 EDT
The same test with 20080418 images, at least on my hardware, passed.
X is definitely not in a hurry to start but eventually it does that.
Should this be considered closed or somewhat different graphics card
will still cause failures?

Note You need to log in before you can comment on or make changes to this bug.