Bug 440397 - lam-libs %post scriptlet: ERROR: Cannot read from source directory (/usr/lib64/lam/etc)
lam-libs %post scriptlet: ERROR: Cannot read from source directory (/usr/lib6...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lam (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Doug Ledford
Brian Brock
:
: 440593 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-03 07:15 EDT by Milan Zazrivec
Modified: 2008-05-21 11:25 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0481
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:25:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Zazrivec 2008-04-03 07:15:48 EDT
Description of problem:
RHEL5.2-Client-20080402.0 / lam-libs 2:7.1.2 12.el5 installation on x86_64
produces following %post scriptlet error:

ERROR: Cannot read from source directory (/usr/lib64/lam/etc)
error: %post(lam-libs-7.1.2-12.el5.x86_64) scriptlet failed, exit status 1

Same thing for i386 package:

ERROR: Cannot read from source directory (/usr/lib/lam/etc)
error: %post(lam-libs-7.1.2-12.el5.i386) scriptlet failed, exit status 1

Version-Release number of selected component (if applicable):
lam-libs-2:7.1.2-12.el5 / RHEL5.2-Client-20080402.0
Comment 2 Doug Ledford 2008-04-03 08:51:06 EDT
I've found the cause of this.  In the openmpi package, I included the
%{_libdir}/%{name}/etc/mpivars.* files as part of the openmpi-libs package, and
attached the %post/%preun scripts to the openmpi-libs package as well.  In lam,
I mistakenly left the scripts attached to the lam-libs package while I moved the
mpivars.* files to the base lam package.  This created a race condition where if
the %post script from the lam-libs package was ran after the base lam package
was installed, then things worked.  If it wasn't, then you get the errors above.
 I have this fixed in my local tree, I just need to get this bug acked to check
into CVS and rebuild.
Comment 5 Alexander Todorov 2008-04-04 08:51:32 EDT
*** Bug 440593 has been marked as a duplicate of this bug. ***
Comment 6 Brock Organ 2008-04-14 17:08:27 EDT
verified fix in RHEL5.2-Server-20080409.0 x86_64 tree:

Installing rsyslog - 2.0.0-11.el5.x86_64
Installing lam-libs - 2:7.1.2-14.el5.x86_64
Installing eruby-libs - 1.0.5-6.1.x86_64
Comment 8 errata-xmlrpc 2008-05-21 11:25:09 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0481.html

Note You need to log in before you can comment on or make changes to this bug.