Bug 440424 - user switcher vs automatic login
user switcher vs automatic login
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-04-03 10:26 EDT by Matthias Clasen
Modified: 2008-04-06 00:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-06 00:11:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2008-04-03 10:26:30 EDT
if I pick "Other" from the user switcher applet, while automatic login is
enabled in gdm, I end up on a login screen with the automatic login timer
ticking. Thats not right. I guess automatic login should only ever run on the
first vt.

Relatedly, we talked about changing the user switcher applet to only show
currently logged in users (without the then redundant checkbox) plus "Other",
since we punted on preselecting the right user...
Comment 1 jmccann 2008-04-03 10:44:09 EDT
I actually thought about this and decided it was ok.  We really only enable the
timed login for live cds and kiosk like things.  In that case if for some reason
you end up on the greeter you really do want to get sent back to the session
after a while.

The only show logged in users is rawhide today.
Comment 2 Matthias Clasen 2008-04-03 12:42:28 EDT
Oh, so if I let the automatic login run to the end, it'll bring me back to my
orignal session...yeah, may be ok then. Just something to note somewhere, I
guess. Longer-term, in a multi-seat future, do we want automatic login to be
tied to specific seats, or be able to specify different configurations per-seat ?

Note You need to log in before you can comment on or make changes to this bug.