Bug 440427 - pkcon is acting odd
pkcon is acting odd
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-03 10:37 EDT by Rahul Sundaram
Modified: 2013-03-13 01:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 05:46:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2008-04-03 10:37:49 EDT
Description of problem:

# rpm -q PackageKit

PackageKit-0.1.11-0.620.20080401git.fc9.hughsie.i386

#  rpm -q PackageKit-cron
package PackageKit-cron is not installed

# pkcon install PackageKit-cron

resolve runtime was 3.0 seconds
    [=======================...................................]   40%          
Error: internal-error : Error in Package Signatures
P
a
c
k
a
g
e
 
P
a
c
k
a
g
e
K
i
t
-
c
r
o
n
-
0
.
1
.
1
1
-
0
.
6
3
0
.
2
0
0
8
0
4
0
2
g
i
t
.
f
c
9
.
h
u
g
h
s
i
e
.
i
3
8
6
.
r
p
m
 
i
s
 
n
o
t
 
s
i
g
n
e
d
install-package runtime was 12.1 seconds    

# rpm -q PackageKit-cron
package PackageKit-cron is not installed
Comment 1 Rahul Sundaram 2008-04-03 10:41:15 EDT
Just found out that, this is because package has not been signed. Yum correctly
deals with this. 
Comment 2 Richard Hughes 2008-04-03 12:14:57 EDT
Hmm. Do you get the one char on each line error with git?
Comment 3 Rahul Sundaram 2008-04-03 12:21:41 EDT
Yeah. This is what I got now

# rpm -q PackageKit
PackageKit-0.1.11-0.630.20080402git.fc9.hughsie.i386

To reproduce, enable gpg check on your repository and try to install any package
from that. Yum will fail noting that the package you are trying to install is
not signed. pkcon acts very odd. 
Comment 4 Tim Lauridsen 2008-04-04 05:46:19 EDT
i have fixed the one char at a line message, but the error is right.
you are adding gpgcheck to a repo with unsigned packages, then it shall fail.

yum will fail with the same error.

Note You need to log in before you can comment on or make changes to this bug.