Bug 44043 - Analog joystick fails to open.
Analog joystick fails to open.
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: joystick (Show other bugs)
7.1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-10 11:05 EDT by Bruce Bigby
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 12:27:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce Bigby 2001-06-10 11:05:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2smp i586)

Description of problem:
I have a standard analog joystick -- F-16 Combat Stick -- that I used to
use in 6.1 with the 2.2.17 SMP kernel.  I had a definition in conf.modules
in 2.2.17 as follows:  
  
alias joystick joy-analog  
  
I also edited my rc.sysinit script in 2.2.17 automatically install the
joystick modules, using 'modprobe joystick'.  
  
However, in RH 7.1 with the 2.4.2 smp kernel, I converted over to
modules.conf, instead.  I also had to change the joystick line to  
  
alias joystick analog  
  
since the name of the analog joystick module is now just 'analog'.  It
seems that the kernel modules tree contains a single subdirectory where all
joystick modules reside, rather than naming each module joy-<name>.  
  
Anyway, I load the analog module, using 'modprobe joystick' and all of the
modules, upon which analog depends, load -- for example, input and gameport
also load.  I've also tried 'modprobe analog' from with the
kernel/char/joystick subdirectory. However, when I run prboom (Doom II), it
cannot open /dev/js0, which is a symbolic link to /dev/input/js0.  I looked
at the permissions on /dev/input/js0 and the value appears to be correct:  
  
crw-------    1 bbigby   root      13,   0 Mar 23 23:37 /dev/input/js0  
  
I shouldn't have to create a new kernel.  I should just be able to load the
proper joystick module(s).  Even jstest can't see the joystick port.  What
am I doing wrong?

How reproducible:
Always

Steps to Reproduce:
1. Access a computer with a standard old-style analog joystick.
2. Load the 'analog' joystick module.
3. Run 'jstest /dev/js0'.
	

Actual Results:  jstest fails to open the joystick.

Expected Results:  jstest should sucessfully open the joystick and run.

Additional info:
Comment 1 Preston Brown 2001-06-25 16:09:43 EDT
you need to modprobe also the ns558 and joydev drivers.
Comment 2 Bruce Bigby 2001-06-25 18:57:20 EDT
I read the Documentation in the joystick.txt file and did the following:

modprobe joydev
modprobe ns558
modprobe analog

I'm not sure that I should use the ns558, because I'm not using the gameport on my SB 32 PnP.  I'm using an independent game port card.  Still, none of the programs can open my joystick port.  The port is 0x201.  My regular analog joystick worked just fine in 6.1.  I have a F16 Combat Stick (CH Flightstick Pro-compatible) it has 2 hats and 6 buttons.  I don't know why it doesn't work. I also performed a 'cat /proc/ioports' but did not find anything that appeared to be a game port.  I'm sure the joystick works.  I tested it from Windows and it used to work fine in RH 6.1 with the 'joy-analog' driver.
Comment 3 Bill Nottingham 2006-08-07 15:03:51 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 4 Bill Nottingham 2006-10-18 12:27:29 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.