Bug 440433 - Mail-notification crash with current Rawhide
Mail-notification crash with current Rawhide
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mail-notification (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dmitry Butskoy
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-03 11:10 EDT by Jonathan Kamens
Modified: 2008-04-17 08:16 EDT (History)
2 users (show)

See Also:
Fixed In Version: 5.2-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-17 07:14:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug-buddy report (331.35 KB, text/plain)
2008-04-03 11:10 EDT, Jonathan Kamens
no flags Details

  None (edit)
Description Jonathan Kamens 2008-04-03 11:10:50 EDT
With updates from yesterday's Rawhide, mail-notification just crashed on me. 
Bug-buddy report attached.
Comment 1 Jonathan Kamens 2008-04-03 11:10:50 EDT
Created attachment 300263 [details]
bug-buddy report
Comment 2 Dmitry Butskoy 2008-04-03 11:24:02 EDT
You mean new version 5.2 ?

Try to uninstall the old 5.0 completely, then install the new 5.2 .

5.2 now uses d-bus instead of bonobo, hence the old session config could try to
run the old path...

Comment 3 Jonathan Kamens 2008-04-04 16:59:51 EDT
I uninstalled mail-notification and mail-notification-plugin and reinstalled
them.  Just crashed again, about a day later.

Did you mean for me to delete and recreate my personal mail-notification
configuration?  You didn't mention that.  If that's what you meant, then please
tell me how to do that.
Comment 4 Dmitry Butskoy 2008-04-07 06:52:17 EDT
Thorsten had reported me recently that mail-notification-5.2 is working under
the current rawhide system...

Hence it could be some specific issue of your environment :(

What happens when you invoke "mail-notification" from the cmdline? 

Couild you install "mail-notification-debuginfo" package and do the debug with
core and gdb?
Comment 5 Jonathan Kamens 2008-04-09 09:11:53 EDT
It crashes intermittently when run from the command line as well.

It doesn't crash right away.  It seems to crash more often when I am actively
using the mailbox, i.e., I suspect that there is a race condition that is
triggering the bug.

Here's the stack trace from gdb when it gets a SEGV:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb7c7eb90 (LWP 21215)]
IA__g_str_hash (v=<value optimized out>) at gstring.c:95
95	  guint32 h = *p;
Missing separate debuginfos, use: debuginfo-install alsa-lib.i386 audiofile.i386
avahi.i386 bug-buddy.i386 cairo.i386 e2fsprogs.i386 elfutils.i386 esound.i386
expat.i386 gail.i386 gcc.i386 gnome-keyring.i386 gtk2-engines.i386 keyutils.i386
krb5.i386 libXau.i386 libXcomposite.i386 libXcursor.i386 libXdmcp.i386
libXext.i386 libXfixes.i386 libXi.i386 libXinerama.i386 libXrandr.i386
libcap.i386 libgnome.i386 libpng.i386 libselinux.i386 libxcb.i386 pixman.i386
(gdb) thread apply all bt

Thread 4 (Thread 0xb687cb90 (LWP 21222)):
#0  0x00110402 in __kernel_vsyscall ()
#1  0x00ae55d7 in __poll (fds=<value optimized out>, 
    nfds=<value optimized out>, timeout=<value optimized out>)
    at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x0014b352 in g_main_context_iterate (context=<value optimized out>, 
    block=<value optimized out>, dispatch=<value optimized out>, self=Could not
find the frame base for "g_main_context_iterate".
)
    at gmain.c:2951
#3  0x0014b98a in IA__g_main_loop_run (loop=<value optimized out>)
    at gmain.c:2850
#4  0x06794f60 in link_io_thread_fn (data=Could not find the frame base for
"link_io_thread_fn".
) at linc.c:396
#5  0x0017213f in g_thread_create_proxy (data=<value optimized out>)
    at gthread.c:635
#6  0x00bb951f in start_thread (arg=<value optimized out>)
    at pthread_create.c:297
#7  0x00aefdbe in clone () from /lib/libc.so.6

Thread 2 (Thread 0xb7c7eb90 (LWP 21215)):
#0  IA__g_str_hash (v=<value optimized out>) at gstring.c:95
#1  0x0013a847 in IA__g_hash_table_lookup (hash_table=<value optimized out>, 
    key=<value optimized out>) at ghash.c:118
#2  0x0805d69b in mn_mailbox_remove_stale_messages_cb (key=0x959ac28, 
    message=0x95a8230, messages=0x9491228) at build/src/mn-mailbox.c:950
#3  0x0013a965 in g_hash_table_foreach_remove_or_steal (
    hash_table=<value optimized out>, func=<value optimized out>, 
    user_data=<value optimized out>, notify=Could not find the frame base for
"g_hash_table_foreach_remove_or_steal".
) at ghash.c:970
#4  0x0805f583 in mn_mailbox_filter_messages (self=0x9466078)
    at build/src/mn-mailbox.c:919
#5  0x080796a7 in mn_imap_mailbox_session_got_messages (priv=0xb7c7e29c)
    at build/src/mn-imap-mailbox.c:2162
#6  0x0807977e in mn_imap_mailbox_enter_fetch_cb (session=0xb7c7e200, 
    priv=0xb7c7e29c) at build/src/mn-imap-mailbox.c:1299
#7  0x08080435 in mn_client_session_run (states=0x8091a80, 
    callbacks=0x8091a60, use_ssl=0, 
    server=0x9465e00 "jik3.kamens.brookline.ma.us", port=143, 
    private=0xb7c7e29c, err=0xb7c7e298) at src/mn-client-session.c:296
#8  0x0807b610 in ___21_mn_imap_mailbox_authenticated_check (mailbox=0x9466078)
    at build/src/mn-imap-mailbox.c:1664
#9  0x08081068 in mn_authenticated_mailbox_check_thread_cb (self=0x9466078)
    at build/src/mn-authenticated-mailbox.c:518
#10 0x0017213f in g_thread_create_proxy (data=<value optimized out>)
    at gthread.c:635
#11 0x00bb951f in start_thread (arg=<value optimized out>)
    at pthread_create.c:297
#12 0x00aefdbe in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb7f80730 (LWP 21205)):
#0  0x00110402 in __kernel_vsyscall ()
#1  0x00ae55d7 in __poll (fds=<value optimized out>, 
    nfds=<value optimized out>, timeout=<value optimized out>)
    at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x0014b352 in g_main_context_iterate (context=<value optimized out>, 
    block=<value optimized out>, dispatch=<value optimized out>, self=Could not
find the frame base for "g_main_context_iterate".
)
    at gmain.c:2951
#3  0x0014b98a in IA__g_main_loop_run (loop=<value optimized out>)
    at gmain.c:2850
#4  0x0314d8e9 in IA__gtk_main () at gtkmain.c:1163
#5  0x0806f8fa in main (argc=1, argv=0xbf99a914) at src/mn-main.c:529
95	  guint32 h = *p;
(gdb) 
Comment 6 Dmitry Butskoy 2008-04-09 11:43:06 EDT
Fixed by a patch from upstream,
https://bugs.launchpad.net/mail-notification/+bug/210915
Comment 7 Jonathan Kamens 2008-04-12 21:56:43 EDT
As far as I know, you can't CLOSE a bug with NEXTRELEASE until the fix is
actualliy in an RPM that has been approved by Fedora QA for inclusion in the
upcoming release.

The mail-notification currently in Rawhide is still crashing, so that can't be
the case here.

Could you please clarify where exactly this bug is fixed and when we will see
the fix in Rawhide?
Comment 8 Dmitry Butskoy 2008-04-14 08:04:55 EDT
> The mail-notification currently in Rawhide is still crashing

It is a reason, why I closed "NEXTRELEASE", not "CURRENTRELEASE" :)

Actually, there is some freeze over rawhide now, because of upcoming Fedora 9 .
I think it is a reason why the new package still is not in the rawhide tree.

You can get the new version from
http://koji.fedoraproject.org/packages/mail-notification/5.2/3.fc9/
Comment 9 Jonathan Kamens 2008-04-14 10:37:20 EDT
Do you mean the F9 is going to ship without the fix, i.e., mail-notification in 
F9 when it ships is going to have a known, frequently occurring crash in it?
Comment 10 Dmitry Butskoy 2008-04-14 10:43:54 EDT
Please, don't worry -- I already have started the update process. It just takes
a little more steps, because of the freeze...
Comment 11 Dmitry Butskoy 2008-04-17 07:14:15 EDT
Now in rawhide repo.
Comment 12 Jonathan Kamens 2008-04-17 08:01:36 EDT
I won't claim to be an expert in the Fedora bugzilla processes, but I think you
need to find somebody who is and get a tutorial :-).  If something's in Rawhide,
you close it with "RAWHIDE" as the disposition, not "CURRENTRELEASE". 
"CURRENTRELEASE" means a bug was reported on a previous release and it's already
fixed in the current release, which is not the case, because your fix has not
yet been released to anybody yet.
Comment 13 Dmitry Butskoy 2008-04-17 08:16:04 EDT
The current rawhide is actually upcoming Fedora 9, rather than usual rawhide.

P.S. Don't be so bureaucratic... ;)

Note You need to log in before you can comment on or make changes to this bug.