Bug 440462 - error with usb-modem
error with usb-modem
Status: CLOSED DUPLICATE of bug 426766
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
8
All Linux
low Severity urgent
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
: 441156 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-03 13:26 EDT by Ulises Guzmann
Modified: 2008-04-07 10:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 10:00:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ulises Guzmann 2008-04-03 13:26:17 EDT
Component: system-config-network
Version: 1.4.3
Summary: TB8a97ef57 NCHardwareList.py:692:load:ValueError: invalid literal for
int() with base 10: 'None'

Traceback (most recent call last):
  File "/usr/sbin/system-config-network-gui", line 166, in runit
    window = mainDialog()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
253, in __init__
    self.load()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
277, in load
    self.loadHardware()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
289, in loadHardware
    hardwarelist = getHardwareList()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line
780, in getHardwareList
    __HWList.load()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line
692, in load
    hw.Modem.BaudRate = int(wvdial[dev]['Baud'])
ValueError: invalid literal for int() with base 10: 'None'

Local variables in innermost frame:
hwconf: <netconfpkg.NCHardwareList.ConfHWConf instance at 0x9df380c>
i: 3
self: HardwareList.Ethernet.eth0.Status=ok
HardwareList.Ethernet.eth0.Name=eth0
HardwareList.Ethernet.eth0.Type=Ethernet
HardwareList.Ethernet.eth0.Card.ModuleName=8139too
HardwareList.Ethernet.eth0.Description=Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+
HardwareList.Ethernet.eth2.Status=ok
HardwareList.Ethernet.eth2.Name=eth2
HardwareList.Ethernet.eth2.Type=Ethernet
HardwareList.Ethernet.eth2.Card.ModuleName=8139too
HardwareList.Ethernet.eth2.Description=Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+
HardwareList.Ethernet.eth1.Status=ok
HardwareList.Ethernet.eth1.Name=eth1
HardwareList.Ethernet.eth1.Type=Ethernet
HardwareList.Ethernet.eth1.Card.ModuleName=8139too
HardwareList.Ethernet.eth1.Description=Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+
HardwareList.Modem.Modem0.Status=configured
HardwareList.Modem.Modem0.Name=Modem0
HardwareList.Modem.Modem0.Modem.DeviceName=/dev/modem
HardwareList.Modem.Modem0.Type=Modem
HardwareList.Modem.Modem0.Description=Generic Modem

isdncard: <netconfpkg.NCisdnhardware.ConfISDN instance at 0x9e20a0c>
hw: Hardware.Status=configured
Hardware.Name=Modem0
Hardware.Modem.DeviceName=/dev/modem
Hardware.Type=Modem
Hardware.Description=Generic Modem

dev: Modem0
wvdial: <netconfpkg.conf.ConfSMB.ConfSMB instance at 0x9ffa0cc>
Comment 1 Harald Hoyer 2008-04-07 09:57:40 EDT
*** Bug 441156 has been marked as a duplicate of this bug. ***
Comment 2 Harald Hoyer 2008-04-07 10:00:31 EDT

*** This bug has been marked as a duplicate of 426766 ***

Note You need to log in before you can comment on or make changes to this bug.