Bug 440497 - Hard lockup on ifup with rt2500pci in 2.6.24.4-64.fc8
Hard lockup on ifup with rt2500pci in 2.6.24.4-64.fc8
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-03 15:55 EDT by Ville Skyttä
Modified: 2008-04-08 02:44 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.6.24.4-74.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 16:36:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2008-04-03 15:55:09 EDT
ifup wlan1 causes a hard lockup of my box with kernel-2.6.24.4-64.fc8.x86_64,
rt2500pci.  No such problems with kernel-2.6.24.3-50.fc8.x86_64 or
kernel-2.6.24.4-74.fc8.x86_64.  No lockup if I just let the modules load but
don't do ifup.

04:08.0 Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)
        Subsystem: Belkin F5D7000 Wireless G Desktop Network Card
        Flags: bus master, slow devsel, latency 64, IRQ 18
        Memory at faafc000 (32-bit, non-prefetchable) [size=8K]
        Capabilities: [40] Power Management version 2
        Kernel driver in use: rt2500pci
        Kernel modules: rt2500pci
Comment 1 John W. Linville 2008-04-03 16:36:42 EDT
If it already works in a later version, I don't really see the point of this 
bug...
Comment 2 Ville Skyttä 2008-04-03 17:31:57 EDT
Well, 2.6.24.4-74.fc8.x86_64 has not even entered pending state in bodhi let
alone updates-testing or updates.  I thought I'd be doing a favor by filing the
bug and thus quite possibly drawing some of the probably incoming dupe reports
into this one until there is an update available in real repos, but *shrug*.
Comment 3 John W. Linville 2008-04-03 19:34:49 EDT
OK, drawing dupes here is a fine suggestion. :-)
Comment 4 Edouard Bourguignon 2008-04-08 02:44:53 EDT
2.6.24.4-74.fc8 doesn't hard lockup anymore but connection is really slow:

wlan0     IEEE 802.11  ESSID:"ouifi-25F2E6"  
          Mode:Managed  Frequency:2.417 GHz  Access Point: 00:11:22:33:44:55   
          Bit Rate=1 Mb/s   Tx-Power=27 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Link Quality=50/100  Signal level=-57 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


Bit rate can be manually forced to 54M, then it seems to work well

wlan0     IEEE 802.11  ESSID:"ouifi-25F2E6"  
          Mode:Managed  Frequency:2.417 GHz  Access Point: 00:11:22:33:44:55   
          Bit Rate=54 Mb/s   Tx-Power=27 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Link Quality=72/100  Signal level=-57 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Note You need to log in before you can comment on or make changes to this bug.