Bug 440504 - undefined reference when linking to libopal
undefined reference when linking to libopal
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: opal (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-03 16:40 EDT by Kjartan Maraas
Modified: 2008-10-11 09:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-11 09:50:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2008-04-03 16:40:28 EDT
Description of problem:

When trying to compile ekiga with jhbuild as part of a GNOME build I see this:

/usr/lib/gcc/i386-redhat-linux/4.3.0/../../../libopal.so: undefined reference to
`PIPSocket::Address::operator*=(PIPSocket::Address const&) const'
/usr/lib/gcc/i386-redhat-linux/4.3.0/../../../libopal.so: undefined reference to
`PIPSocket::InterfaceEntry::InterfaceEntry(PString const&, PIPSocket::Address
const&, PIPSocket::Address const&, PString const&, PString const&)'
collect2: ld returned 1 exit status
make[3]: *** [ekiga] Error 1

This is when building against the system installed libopal.
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kjartan Maraas 2008-04-24 08:16:29 EDT
Some more context:

Trying to build ekiga on current Fedora development releases give the following
error:

g++ -g -O2 -o ekiga accounts.o addressbook.o callbacks.o callshistory.o chat.o
config.o druid.o history.o main.o misc.o preferences.o tools.o statusicon.o
audio.o fakevideoinput.o videoinput.o videooutput.o accountshandler.o ekiga.o
manager.o h323.o pcss.o sip.o urlhandler.o stun.o bonobo.o avahi.o -pthread
-pthread  ../lib/.libs/libekiga.a -L/opt/gnome2/lib /opt/gnome2/lib/libesd.so
/opt/gnome2/lib/libaudiofile.so -lm /opt/gnome2/lib/libgnomeui-2.so -lSM -lICE
/opt/gnome2/lib/libbonoboui-2.so /opt/gnome2/lib/libgnomevfs-2.so
/opt/gnome2/lib/libgnomecanvas-2.so /opt/gnome2/lib/libart_lgpl_2.so
/opt/gnome2/lib/libgtk-x11-2.0.so /opt/gnome2/lib/libgdk-x11-2.0.so
/opt/gnome2/lib/libatk-1.0.so /opt/gnome2/lib/libgio-2.0.so
/opt/gnome2/lib/libgdk_pixbuf-2.0.so /opt/gnome2/lib/libpangocairo-1.0.so
/opt/gnome2/lib/libpango-1.0.so -lcairo /opt/gnome2/lib/libebook-1.2.so
/opt/gnome2/lib/libgnome-2.so -lpopt /opt/gnome2/lib/libedataserver-1.2.so
-lxml2 /opt/gnome2/lib/libgconf-2.so /opt/gnome2/lib/libbonobo-2.so
/opt/gnome2/lib/libbonobo-activation.so /opt/gnome2/lib/libgmodule-2.0.so
/opt/gnome2/lib/libORBit-2.so /opt/gnome2/lib/libgthread-2.0.so -lrt
/opt/gnome2/lib/libgobject-2.0.so -lavahi-common -lavahi-client -lavahi-glib
/opt/gnome2/lib/libglib-2.0.so -lSDL -lpt -lopal -ldl -lpthread   -Wl,--rpath
-Wl,/opt/gnome2/lib -Wl,--rpath -Wl,/opt/gnome2/lib
/usr/lib/gcc/i386-redhat-linux/4.3.0/../../../libopal.so: undefined reference to
`PIPSocket::Address::operator*=(PIPSocket::Address const&) const'
/usr/lib/gcc/i386-redhat-linux/4.3.0/../../../libopal.so: undefined reference to
`PIPSocket::InterfaceEntry::InterfaceEntry(PString const&, PIPSocket::Address
const&, PIPSocket::Address const&, PString const&, PString const&)'
collect2: ld returned 1 exit status
make[3]: *** [ekiga] Error 1
make[3]: Leaving directory `/home/kmaraas/cvs/gnome/ekiga-2.0.11/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/kmaraas/cvs/gnome/ekiga-2.0.11/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/kmaraas/cvs/gnome/ekiga-2.0.11'
make: *** [all] Error 2
*** error during stage build of ekiga: ########## Error running make   *** [30/108]

Comment 2 Bug Zapper 2008-05-14 04:38:29 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Daniel Veillard 2008-05-19 04:01:53 EDT
See
https://bugzilla.redhat.com/show_bug.cgi?id=441202

there have been updates (in Testing ATM) for Opal/Ekiga on F-9

Daniel
Comment 4 Peter Robinson 2008-09-29 10:15:51 EDT
Can you test this issue on either the current release in Fedora 9 or the new F-10/rawhide release. I believe it should be fixed.
Comment 5 Kjartan Maraas 2008-09-30 03:34:58 EDT
looks like current ekiga wants ptlib 2.4.1 and rawhide only has 2.3.1...
Comment 6 Peter Robinson 2008-09-30 03:40:51 EDT
2.4.1 is in rawhide according to http://download.fedora.redhat.com/pub/fedora/linux/development/source/SRPMS/ maybe it hasn't synced out to your mirror yet. 2.3.1 is the version that came with F-10 beta.
Comment 7 Peter Robinson 2008-10-11 08:02:10 EDT
Is this still an issue?
Comment 8 Kjartan Maraas 2008-10-11 09:41:19 EDT
Let's just close this one. I can file a new bug if it still happens when rawhide catches up to the ever changing requirements in ekiga trunk. They now require libpt-2.4.1 :-/
Comment 9 Kjartan Maraas 2008-10-11 09:41:59 EDT
2.4.2 I mean...
Comment 10 Peter Robinson 2008-10-11 09:50:45 EDT
unfortunately rawhide will never catch up to ekiga trunk. The development of ekiga is very dependent on the development of both ptlib and opal so each version of ekiga is usually dependent on a specific version of opal and ptlib.

Note You need to log in before you can comment on or make changes to this bug.