Bug 440544 - syslog: lots of b43 PHY transmission error messages
syslog: lots of b43 PHY transmission error messages
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i386 Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
: Reopened
: 466933 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-03 18:09 EDT by sean
Modified: 2009-03-04 14:40 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-04 14:40:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sean 2008-04-03 18:09:00 EDT
Description of problem:
Using the new firmware for b43, syslog is full of:
........
Apr  3 17:57:40 notebook kernel: printk: 22 messages suppressed.
Apr  3 17:57:40 notebook kernel: b43-phy0 ERROR: PHY transmission error
Apr  3 17:57:46 notebook kernel: printk: 23 messages suppressed.
Apr  3 17:57:55 notebook kernel: printk: 40 messages suppressed.
.............

other the ERROR messages, the driver seems to be working just fine.
 
Version-Release number of selected component (if applicable):
kernel-2.6.24.4-64.fc8

kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
lspci -v
.........
Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 01)
        Subsystem: AMBIT Microsystem Corp. Unknown device 0422
        Flags: bus master, fast devsel, latency 0, IRQ 17
        Memory at f8000000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 2
        Capabilities: [58] Message Signalled Interrupts: Mask- 64bit- Queue=0/0
Enable-
        Capabilities: [d0] Express Legacy Endpoint, MSI 00
        Kernel driver in use: b43-pci-bridge
        Kernel modules: ssb
Comment 1 John W. Linville 2008-04-04 07:49:40 EDT
Have you tried the older firmware (the one that triggers the "deprecated" 
message)?  Do you get similar PHY error messages with it?

Could you also try this kernel?

   http://koji.fedoraproject.org/koji/buildinfo?buildID=44648

Michael, the kernel at the link above (2.6.24.4-69.fc8) has wireless bits 
matching the master-2008-04-01 tag of the wireless-testing tree.  The one in 
the original comment (2.6.24.4-64.fc8) should match the master-2008-03-27 tag 
of that tree.
Comment 3 sean 2008-04-06 13:48:50 EDT
The older firmware does NOT generate the PHY error messages.

I'll try the koji kernel.

sean
Comment 4 sean 2008-04-06 14:27:20 EDT
Tried the koji kernel:

uname -a
Linux notebook 2.6.24.4-69.fc8

Same messages:

b43-phy0: Broadcom 4311 WLAN found
input: b43-phy0 as /class/input/input8
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
........
Apr  6 14:24:33 notebook kernel: b43-phy0 ERROR: PHY transmission error
Apr  6 14:24:36 notebook kernel: printk: 11 messages suppressed.
Apr  6 14:24:42 notebook kernel: printk: 15 messages suppressed.
................
Comment 5 sean 2008-04-18 11:04:59 EDT
With 2.6.24.4-69.fc8 some additional messages:

............
b43-phy0 ERROR: PHY transmission error
printk: 42 messages suppressed.
wlan0: RX too short data frame payload
printk: 16 messages suppressed.
wlan0: RX too short data frame payload
...............

I hadn't noticed the "RX too short data frame..." messages.
Comment 6 John W. Linville 2008-07-08 16:00:20 EDT
Are you continuing to experience this problem with current kernels?
Comment 7 sean 2008-07-09 13:51:33 EDT
Yes.

 uname -a
Linux 2.6.25.9-76.fc9.i686

dmesg
........
b43-phy0 ERROR: PHY transmission error
printk: 20 messages suppressed.
b43-phy0 ERROR: PHY transmission error
b43-phy0 ERROR: PHY transmission error
b43-phy0 ERROR: PHY transmission error
b43-phy0 ERROR: PHY transmission error

Comment 8 sean 2008-07-31 14:37:09 EDT
2.6.25.11-97.fc9.i686

Just checked again. Nothing. Probably 2.6.25.10. The messages stopped 2 pm, 
July 22.

 cat /var/log/mess* | grep PHY
.........................
Jul 22 14:00:14 notebook kernel: b43-phy0 ERROR: PHY transmission error
Jul 22 14:00:19 notebook kernel: b43-phy0 ERROR: PHY transmission error
Jul 22 14:00:25 notebook kernel: b43-phy0 ERROR: PHY transmission error
Jul 26 13:43:49 notebook kernel: eth0: Tigon3 [partno(BCM95787m) rev b002
PHY(5787)] (PCI Express) 10/100/1000Base-T Ethernet 00:1d:72:05:4a:68


Comment 9 sean 2008-08-18 11:59:57 EDT
It's back:

Aug 18 11:47:49 notebook kernel: b43-phy0 ERROR: PHY transmission error
Aug 18 11:47:55 notebook kernel: printk: 70 messages suppressed.
Aug 18 11:47:55 notebook kernel: b43-phy0 ERROR: PHY transmission error
Aug 18 11:48:01 notebook kernel: printk: 51 messages suppressed.
Aug 18 11:48:01 notebook kernel: b43-phy0 ERROR: PHY transmission error

2.6.25.14-108.fc9.i686

(sigh)
Comment 10 sean 2008-09-13 00:33:55 EDT
uname -a
Linux jay-notebook 2.6.26.3-29.fc9.i686 #1 SMP Wed Sep 3 03:42:27 EDT 2008 i686 i686 i386 GNU/Linux


dmesg
.......
b43-phy0 ERROR: PHY transmission error
__ratelimit: 4 messages suppressed
b43-phy0 ERROR: PHY transmission error
__ratelimit: 17 messages suppressed
b43-phy0 ERROR: PHY transmission error
__ratelimit: 7 messages suppressed
b43-phy0 ERROR: PHY transmission error
b43-phy0 ERROR: PHY transmission error
__ratelimit: 21 messages suppressed
b43-phy0 ERROR: PHY transmission error
__ratelimit: 38 messages suppressed
b43-phy0 ERROR: PHY transmission error
b43-phy0 ERROR: PHY transmission error
__ratelimit: 4 messages suppressed
b43-phy0 ERROR: PHY transmission error
ACPI: EC: GPE storm detected, disabling EC GPE
Comment 11 sean 2008-10-03 11:06:13 EDT
It's still here, filling up the logs.

uname -a
Linux notebook 2.6.26.5-45.fc9.i686 #1 SMP Sat Sep 20 03:45:00 EDT 2008 i686 i686 i386 GNU/Linux

.............
Oct  3 11:03:36 notebook kernel: __ratelimit: 8 messages suppressed
Oct  3 11:03:36 notebook kernel: b43-phy0 ERROR: PHY transmission error
Oct  3 11:03:40 notebook kernel: __ratelimit: 19 messages suppressed
Oct  3 11:03:40 notebook kernel: b43-phy0 ERROR: PHY transmission error
Oct  3 11:03:44 notebook kernel: __ratelimit: 23 messages suppressed
Oct  3 11:03:44 notebook kernel: b43-phy0 ERROR: PHY transmission error
Oct  3 11:03:47 notebook kernel: __ratelimit: 6 messages suppressed
Oct  3 11:03:47 notebook kernel: b43-phy0 ERROR: PHY transmission error
Oct  3 11:03:54 notebook kernel: __ratelimit: 33 messages suppressed
Oct  3 11:03:54 notebook kernel: b43-phy0 ERROR: PHY transmission error
Oct  3 11:03:58 notebook kernel: __ratelimit: 2 messages suppressed
Oct  3 11:03:58 notebook kernel: b43-phy0 ERROR: PHY transmission error
.................
Comment 12 John W. Linville 2008-10-03 11:38:23 EDT
Other than the log noise, do you have connectivity problems?  I.E. is this just a nuisance?  Or is there a functional problem?
Comment 13 sean 2008-10-05 21:07:03 EDT
AFAICT, no functional problem. But I keep becoming aware of it when I have any another problem. dmesg has nothing but these msgs.
Comment 14 John W. Linville 2008-11-12 09:39:19 EST
*** Bug 466933 has been marked as a duplicate of this bug. ***
Comment 15 John W. Linville 2009-02-13 14:51:16 EST
What is the latest kernel you have tried?  I'm not seeing this on the b43 devices I have, but it seems to be card specific from the reports I've heard...
Comment 16 sean 2009-02-28 19:19:57 EST
That laptop's display gave out last December, so now it just sits headless with a wired connection.

So no more messages.

Note You need to log in before you can comment on or make changes to this bug.