Bug 440566 - Firefox window resizing doesn't work
Firefox window resizing doesn't work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-03 21:53 EDT by E Mair
Modified: 2008-07-22 18:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-22 18:45:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description E Mair 2008-04-03 21:53:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; sv-SE; rv:1.8.1.13) Gecko/20080325 Fedora/2.0.0.13-1.fc8 Firefox/2.0.0.13

Description of problem:
When trying to resize the Firefox window using a corner (X+Y size) "drag handle", the window will not respond correctly. The size changes seemingly randomly. Eventually the window disappears. Three processes will still be running; firefox-bin, run-mozilla.sh, and firefox, but the window and whatever you were doing in that is gone.

Resizing the window only horizontally or vertically works fine with the respective side "handles".

As far as I have noticed, this only affects Firefox windows, no other app.



Version-Release number of selected component (if applicable):
firefox-2.0.0.13-1.fc8

How reproducible:
Always


Steps to Reproduce:
1. Try to resize a Firefox window using a corner handle.
2. Watch the window move around like crazy, and then disappear.


Actual Results:


Expected Results:


Additional info:
Comment 1 E Mair 2008-04-03 21:59:11 EDT
To be specific, it's resizing only with the lower right corner "handle" that
doesn't work.
Comment 2 Matěj Cepl 2008-07-01 19:44:10 EDT
Weird, does running the firefox with -safe-mode parameter helps?

Could I get output of the command

	rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*

Thanks in advance.
Comment 3 E Mair 2008-07-22 17:57:38 EDT
Sorry about my delayed feedback, I haven't been much at my F8 computer lately.

Thanks for the -safe-mode tip. This seems to be related to Firefox themes. I
have 4 themes installed in addition to the default one: GrayModern2, Modern
Aluminum, Nautipolis for Firefox, Orbit Yellow 2006. With the default theme and
Orbit Yellow 2006 resizing will work normally, the other 3 makes the bug appear.

BTW, output from the RPM query:
$ rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*
firefox-2.0.0.16-1.fc8
firefox-devel-2.0.0.16-1.fc8
Comment 4 Matěj Cepl 2008-07-22 18:45:50 EDT
OK, then I am sorry -- this is probably bug in themes, which we don't provide
and don't support.

Closing as NOTABUG

Note You need to log in before you can comment on or make changes to this bug.