Bug 440591 - virt-manager: Add 'double click to connect' hint to connection row tooltip
virt-manager: Add 'double click to connect' hint to connection row tooltip
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-04 05:05 EDT by Jóhann B. Guðmundsson
Modified: 2009-12-03 18:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-03 18:53:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2008-04-04 05:05:37 EDT
Description of problem:

Instead of having to right click and choose connect, 
users could just click a connect button..

And I somehow feel the order of buttons is wrong.

I feel it should be.

[ Connect ][New][Open][Details][Delete]

( Added the missing connect button there ) 

:)
 
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Berrange 2008-04-04 07:54:18 EDT
You can simply double-click to activate it. In latest upstream you can also mark
connections to auto-connect at startup, so I don't feel there's a need for extra
buttons.

As for button ordering, I'm undecided - will have to try it out and see how well
it works.
Comment 2 Jóhann B. Guðmundsson 2008-04-04 08:35:33 EDT
I had absolutely no idea I could do that..

That ofcourse obsoletes the need for an extra button.
( Connect/disconnect should have been the same button )

You might then want to add a info msg box when mouse pointer is over it 
"Double click to connect" so user can instantly know of this feature.  

Since double click can be used to connect I think users 
should also be able to use double click to disconnect.

Of course with the "Double click to disconnect" 
info msg box when mouse pointer is over it.

How do you feel about keyboard shortcuts 

<ctrl>-c # Connect
<ctrl>-d # Disconnect
<ctrl>-n # New
Comment 3 Jon Stanley 2008-04-23 16:30:22 EDT
Adding FutureFeature keyword to RFE's.
Comment 4 Cole Robinson 2009-10-21 10:39:21 EDT
Tooltip double click hint added upstream;

http://hg.fedorahosted.org/hg/virt-manager/rev/14847cca4510
Comment 5 Mark McLoughlin 2009-10-29 12:38:57 EDT
Adding to F12VirtTarget, but it'd probably be fine to close as resolved upstrem
Comment 6 Cole Robinson 2009-12-03 18:53:05 EST
This should be fixed in virt-manager-0.8.1-1.fc13 which will be in the next rawhide compose.

Note You need to log in before you can comment on or make changes to this bug.