Bug 440668 - Rhythmbox cannot transfer some files to VFAT iPods
Summary: Rhythmbox cannot transfer some files to VFAT iPods
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rhythmbox
Version: rawhide
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-04 13:27 UTC by Brad Walker
Modified: 2008-04-04 13:42 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2008-04-04 13:42:54 UTC


Attachments (Terms of Use)

Description Brad Walker 2008-04-04 13:27:10 UTC
Description of problem:
On Windows-formatted iPods, Rhythmbox cannot write songs with filenames that
violate VFAT naming conventions (no :, ?, etc.). Sometimes it writes them, but
only when RB truncates the invalid characters off the filename.

Examples:
Rhythmbox won't transfer "02 Humoresque: City Montage.flac" with the colon near
the beginning.
Rhythmbox will transfer "06 Violin Sonata No. 1 in G minor, BWV 1001: IV.
Presto.flac" since it cuts off most of the end of the filename.


Version-Release number of selected component (if applicable):
rhythmbox-0.11.5-5.fc9.x86_64

How reproducible:
100% with a filename with an invalid character near the beginning.


Actual results:
Rhythmbox pops up a "cannot write file" error dialog.


Expected results:
Rhythmbox writes file without problems.


Additional info:
Rhythmbox has this in the GNOME bugzilla:
http://bugzilla.gnome.org/show_bug.cgi?id=374078
I'm writing this report because I'd like to see the patch attached to that
ticket (http://bugzilla.gnome.org/attachment.cgi?id=79726&action=view) in
Fedora's distribution until rhythmbox commits a cleaner solution. I've tested
the patch with rhythmbox-0.11.5-3.fc9.x86_64 and it fixed the file transfer problem.

Comment 1 Bastien Nocera 2008-04-04 13:42:54 UTC
Added the patch in rhythmbox-0.11.5-7


Note You need to log in before you can comment on or make changes to this bug.