Bug 440701 - Package kit should not refer to yum in text messages
Package kit should not refer to yum in text messages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-04 11:08 EDT by James Antill
Modified: 2008-04-07 05:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 05:22:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Antill 2008-04-04 11:08:38 EDT
Description of problem:
 See bug#440689 ... if people see things like "yum cache rebuilt" they log bugs
against yum because there is no "add / remove programs".

 So to alleviate this PK and gnome-PK should _not_ be outputting the yum name,
just saying "cache rebuilt" ... or even "packagekit backend cache".
 This should also mean you can use the same messages/translations cross distro.
Comment 1 Richard Hughes 2008-04-04 11:32:06 EDT
This detailed error string is from the backend (and hence untranslated). Feel
free to change any "yum"'s to "the backed" in the yumBackend.py file if you have
a spare few mins.
Comment 2 James Antill 2008-04-04 12:47:52 EDT
 Again git HEAD:

http://people.redhat.com/jantill/yum/pk-no-yum-msgs.patch
Comment 3 Richard Hughes 2008-04-05 06:17:30 EDT
I've made a few changes, then merged your patch, thanks.

Note You need to log in before you can comment on or make changes to this bug.