Bug 440960 - Default External Enrollment UI problem
Default External Enrollment UI problem
Status: CLOSED ERRATA
Product: Dogtag Certificate System
Classification: Community
Component: TPS (Show other bugs)
1.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Jack Magne
Chandrasekar Kannan
:
Depends On:
Blocks: 443788
  Show dependency treegraph
 
Reported: 2008-04-04 13:46 EDT by Jack Magne
Modified: 2015-01-04 18:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 19:28:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
TPS UI fix. (2.86 KB, text/plain)
2008-04-04 17:20 EDT, Jack Magne
no flags Details

  None (edit)
Description Jack Magne 2008-04-04 13:46:49 EDT
Description of problem:

The default external UI provided by TPS is used by the ESC client to display a
possibly customized card enrollment experience to the user.

Out of the box, we want to provide working default UI that serves as a starting
point. Right now the enrollment does not work due to some minor issues.

Version-Release number of selected component (if applicable):

1.0.0-1

How reproducible:

Always.

Steps to Reproduce:
1.Install the Dogtag CA.
2.Install the Dogtag TPS.
3.Use ESC to format a smartcard.
4.Later insert the formatted token into the computer.
5.ESC will ask to enroll the token. Accept.
6.The external enrollment UI will appear.
7.Fill out the form and attempt an enrollment.

  
Actual results:

The hitting the "Enroll" button will do nothing.

Expected results:

The actual enrollment process should be initiated.

Additional info:
Comment 1 Jack Magne 2008-04-04 17:20:27 EDT
Created attachment 301348 [details]
TPS UI fix.

Fix for default external TPS enrollment UI.
Comment 2 Matthew Harmsen 2008-04-04 17:58:23 EDT
(id=301348) +mharmsen
Comment 3 Jack Magne 2008-04-04 18:26:42 EDT
svn status


M      linux/tps-ui/shared/cgi-bin/home/Enroll.html
M      linux/tps-ui/shared/docroot/esc/home/EnrollSuccess.html
M      linux/tps-ui/shared/docroot/esc/home/util.js
M      linux/tps-ui/pki-tps-ui.spec

Sending        linux/tps-ui/pki-tps-ui.spec
Sending        linux/tps-ui/shared/cgi-bin/home/Enroll.html
Sending        linux/tps-ui/shared/docroot/esc/home/EnrollSuccess.html
Sending        linux/tps-ui/shared/docroot/esc/home/util.js
Transmitting file data ....
Committed revision 18.
Comment 5 Chandrasekar Kannan 2009-07-04 20:58:22 EDT
this works fine.

1.Install the Dogtag CA.
2.Install the Dogtag TPS.
3.Use ESC to format a smartcard.
4.Later insert the formatted token into the computer.
5.ESC will ask to enroll the token. Accept.
6.The external enrollment UI will appear.
7.Fill out the form and attempt an enrollment.

marking bug VERIFIED

Note You need to log in before you can comment on or make changes to this bug.