Bug 440971 - SELinux denial from sshd on every login
SELinux denial from sshd on every login
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-04-04 14:44 EDT by Will Woods
Modified: 2008-04-06 07:17 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-06 07:17:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Will Woods 2008-04-04 14:44:26 EDT
This happens every time I log in to the machine (or scp a file to it):

host=norfair.test.redhat.com type=AVC msg=audit(1207334595.476:37): avc: denied
{ link } for pid=4484 comm="sshd"
scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023
tcontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tclass=key 

host=norfair.test.redhat.com type=SYSCALL msg=audit(1207334595.476:37):
arch=c000003e syscall=250 success=no exit=-13 a0=8 a1=fffffffc a2=fffffffd
a3=7fff37966da0 items=0 ppid=2214 pid=4484 auid=4294967295 uid=500 gid=500
euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295
comm="sshd" exe="/usr/sbin/sshd" subj=system_u:system_r:sshd_t:s0-s0:c0.c1023
key=(null)
Comment 1 Daniel Walsh 2008-04-06 07:17:21 EDT
This is a known kernel issue, and a bugzilla has been opened.  I am dontaudit
this in the latest policy until the issue is fixed.

You can allow this for now by executing 

# audit2allow -M mypol -i /var/log/audit/audit.log 
# semodule -i mypol.pp

Fixed in selinux-policy-3.3.1-29.fc9

Note You need to log in before you can comment on or make changes to this bug.