Bug 44100 - Upgrade fails to configure ppp modules in /etc/modules.conf
Summary: Upgrade fails to configure ppp modules in /etc/modules.conf
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-11 04:28 UTC by Henri Schlereth
Modified: 2014-03-17 02:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-24 15:56:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Henri Schlereth 2001-06-11 04:28:40 UTC
Description of Problem:
Since the split of the ppp module into several more modules the upgrade
(from 7.0 -> 7.1) fails to put the new modules in modules.conf

How Reproducible:
Upgrade a 7.0 box with ppp to 7.1 and have onboot = yes in ifcfg-ppp0

Steps to Reproduce:
1. Reboot after upgrade
2. 
3. 

Actual Results:
It either hangs or fails.

Expected Results:
Should boot up and dial as part of bring up the network

Additional Information:
the temporary fix is to add the modules by hand, add persist to
PPPOPTIONS(if needed) and
depmod -a ; ifup ppp0

Note: this may properly belong to ppp but I thought it should go here as
part of the
install/upgrade process.

Comment 1 Brent Fox 2001-06-14 17:34:36 UTC
Nalin, I don't think that the installer handles this sort of conversion during
upgrades.  Does this sound like more of a ppp problem to you?

Comment 2 Preston Brown 2001-08-24 13:50:07 UTC
bill, trond, this should be handled via the network init scripts.


Comment 3 Bill Nottingham 2001-08-24 15:55:42 UTC
No, modutils should handle the new ppp aliases fine.

Comment 4 Bill Nottingham 2001-08-24 15:56:20 UTC
No, modutils should handle the new ppp aliases fine.


Note You need to log in before you can comment on or make changes to this bug.