Bug 44107 - /bin/login is not setuid to root
Summary: /bin/login is not setuid to root
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: util-linux   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Erik Troan
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-11 13:15 UTC by Need Real Name
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-11 16:29:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-06-11 13:15:15 UTC
Description of Problem:
I cannot use login in a shell to login to another account.
The error message says that the password has expired. 
I eventually tracked this down in the source for /bin/login.
It just means that /bin/login has failed to access the /etc/shadow
file since it is not setuid to root.

This problem appears in both 7.0 and 7.1. The rpm shows that /bin/login
is not setuid to root.

How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Erik Troan 2001-06-11 16:29:06 UTC
This feature has been disabled in Red Hat (since Red Hat 4.0) because it
conflicts with PAM session management.


Note You need to log in before you can comment on or make changes to this bug.