Bug 441111 - RFE: own /etc/kernel/ and /etc/kernel/postinst.d/
RFE: own /etc/kernel/ and /etc/kernel/postinst.d/
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-06 07:19 EDT by Thorsten Leemhuis
Modified: 2008-04-24 00:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: 6.0.49-1.fc9
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-24 00:52:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Leemhuis 2008-04-06 07:19:37 EDT
Description of problem:
Mkinitrd since applying the RFE from Bug 433121 supports calling stuff from
/etc/kernel/postinst.d/ via /sbin/new-kernel-pkg in rpmposttrans; different
packages might use this directory, but the directory does not exists. That's
bad, as each and every package that might want to use it would need to own it,
which is not acceptable according to the fedora packaging guidelines. Thus I'd
say the mkinitrd package should create and own those packages

Version-Release number of selected component (if applicable):
mkinitrd-6.0.41-1.fc9.x86_64

Additional info:
Mattdm, do you agree with that? If yes I can prepare and apply a patch for the
spec file.

While at it: Matt, in your patch posted in 
https://www.redhat.com/archives/fedora-kernel-list/2008-February/msg00083.html
there were different hooks for install (/etc/kernel/postinst.d/) and uninstall
(/etc/kernel/prerm.d/). When looking at /sbin/new-kernel-pkg from rawhide
mkinitrd it seems during both install and uninstall scripts from
/etc/kernel/postinst.d/ get called. Is that the intended way or is there a
mis-merge?
Comment 1 Thorsten Leemhuis 2008-04-06 14:19:16 EDT
While at it (2): The code in /sbin/new-kernel-pkg is broken in any case. See
line 192:

[...]
files="/etc/kernel/postinst.d/*[^~] /etc/kernel/postinst.d/$version/*[^~]"
for f in files ; do
[...]

s/in files/in $files/ might help a lot ;-)
Comment 2 Peter Jones 2008-04-07 10:42:26 EDT
Will be fixed in 6.0.42, thanks.
Comment 3 Jon Stanley 2008-04-23 16:29:51 EDT
Adding FutureFeature keyword to RFE's.
Comment 4 Thorsten Leemhuis 2008-04-24 00:52:11 EDT
this actually was fixed; closing

Note You need to log in before you can comment on or make changes to this bug.