Bug 441115 - init 3 does not kill X
init 3 does not kill X
Product: Fedora
Classification: Fedora
Component: upstart (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Casey Dahlin
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-04-06 08:22 EDT by Need Real Name
Modified: 2014-06-18 04:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-09 17:34:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2008-04-06 08:22:11 EDT
Switching to runlevel 3 does not kill X.
Comment 1 Casey Dahlin 2008-04-06 15:05:40 EDT
Could you please verify your version? We had this bug previously and it had
fixed it.
Comment 2 Need Real Name 2008-04-06 15:11:20 EDT
Comment 3 Bill Nottingham 2008-04-07 12:12:33 EDT
How are you starting X? What display manager (not that it *should* matter, but...)
Comment 4 Warren Togami 2008-04-07 13:08:19 EDT

Just tested this switching between init 5 and init 3.  It seems to be doing the
right thing here.
Comment 5 Casey Dahlin 2008-04-09 16:21:43 EDT
Looks good to me too. What version of event-compat-sysv? What's the output of
/sbin/initctl status prefdm before and after init 3?
Comment 6 Need Real Name 2008-04-09 17:11:25 EDT
Almost works now, X exits, but I don't see the init script messages as I should.
Comment 7 Casey Dahlin 2008-04-09 17:21:24 EDT
Is what you are now seeing potentially the same as this issue? :


If so, I'll mark this as a duplicate and have you CC'd in on that bug.
Comment 8 Need Real Name 2008-04-09 17:31:10 EDT
Yes, but this bug is not a duplicate, this bug has been fixed, so I will add
myself to that bug, and this bug can be closed.
Comment 9 Casey Dahlin 2008-04-09 17:34:58 EDT
Ok then.

Note You need to log in before you can comment on or make changes to this bug.