Bug 441117 - yum doesnt let me type yes
yum doesnt let me type yes
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 441024 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-06 08:51 EDT by Need Real Name
Modified: 2014-01-21 18:02 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-06 11:10:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2008-04-06 08:51:51 EDT
# yum upgrade

Transaktionszusammenfassung
=============================================================================
Installieren        2 Pakete(e)         
Aktualisieren      26 Pakete(e)         
Enfernen          2 Paket(e)         

Gesamtgrösse: 57 M
Ist dies richtig? [y/N] :y
Ist dies richtig? [y/N] :y
Ist dies richtig? [y/N] :y

Running with yum -y upgrade works.
Comment 1 Tim Lauridsen 2008-04-06 11:10:31 EDT
it is a translation bug, should have been [j/N], fixed upstream
Comment 2 Tim Lauridsen 2008-04-06 11:18:02 EDT
*** Bug 441024 has been marked as a duplicate of this bug. ***
Comment 3 Tim Niemueller 2008-04-06 11:33:01 EDT
Will there be the possibility to type y/n always regardless of locale? That'd be
really helpful...
Comment 4 Need Real Name 2008-04-06 12:06:32 EDT
+1
Comment 5 seth vidal 2008-04-06 12:21:39 EDT
No, I can foresee a translation where n will be the char for 'yes' at which
point we're screwed.

Comment 6 Tim Niemueller 2008-04-06 13:15:37 EDT
Is there actually such a case already or is this just a wild guess? I'd rather
add an extra check and print an extra warning if the meaning of "n" is reversed
rather than annoying current users that are used to type 'y' instead of the
localized string - at least it's going to annoy me.
Comment 7 Seth Vidal 2008-04-06 17:05:11 EDT
If you want to deal with yum in english then set your locale/lang when running yum.


Note You need to log in before you can comment on or make changes to this bug.