Bug 441163 - Linux Fedora 8 changes to DST on wrong day
Linux Fedora 8 changes to DST on wrong day
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-06 18:45 EDT by Gregory Kizior
Modified: 2008-04-08 02:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-08 02:15:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gregory Kizior 2008-04-06 18:45:35 EDT
In California, daylight saving time changed to PDT on March 9th. After that
date, my dual-boot (WindowsXP) machine showed Fedora 8 one hour behind Windows. 
I blamed Windows and set Windows 'back' one hour to agree with Linux.
I used the NTP feature in "Adjust Time & Date" to make sure Linux was right.

Today, the old "change to DST" date, Fedora 8 shows the time to be 10:45 when it
is really 11:45.

So it seems Fedora 8 is doing the DST adjustment on the old date.

It would be very annoying to have to manually adjust the time twice a year. I
transfer files between Windows and Linux regularly and expect the timestamp on a
file to be correct.
Comment 1 Dave Jones 2008-04-06 20:02:52 EDT
Jakub, any ideas if tzdata is somehow related to this ?
I'm not clear how this could be a kernel bug, as it has no notion of dst
changeover dates.
Comment 2 Jakub Jelinek 2008-04-07 03:36:52 EDT
The tzdata for America/Los_Angeles is correct since September 2005.  So if it
changes time at the wrong date, you must be using a wrong timezone.  Try:
date -d '2008-03-08 00:00 UTC'
date -d '2008-03-11 00:00 UTC'
date -d '2008-04-05 00:00 UTC'
date -d '2008-04-08 00:00 UTC'
/usr/sbin/zdump -v /etc/localtime | grep 2008
and then with explicit America/Los_Angeles timezone:
TZ=America/Los_Angeles date -d '2008-03-08 00:00 UTC'
TZ=America/Los_Angeles date -d '2008-03-11 00:00 UTC'
TZ=America/Los_Angeles date -d '2008-04-05 00:00 UTC'
TZ=America/Los_Angeles date -d '2008-04-08 00:00 UTC'
/usr/sbin/zdump -v America/Los_Angeles | grep 2008
Comment 3 Chuck Ebbert 2008-04-07 19:25:45 EDT
If you are dual-booting Linux and XP you pretty much have to do the DST
adjustment manually.

XP requires you to keep the CMOS clock in local time and writes the new time to
the clock when it updates for DST. Since XP uses local time Linux must also use
that for the hardware clock. Then on or after the day DST changes they will both
update the clock and it will end up advancing by two hours.
Comment 4 Jakub Jelinek 2008-04-08 02:15:49 EDT
In private mail the reporter said he was actually mistakenly using the
Pacific/Tijuana timezone rather than America/Los_Angeles.

Note You need to log in before you can comment on or make changes to this bug.