Bug 441204 - General protection fault
General protection fault
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 02:18 EDT by Dominick Grift
Modified: 2008-04-14 18:07 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-14 18:07:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominick Grift 2008-04-07 02:18:46 EDT
Description of problem:
System locks up

Version-Release number of selected component (if applicable):
2.6.25-0.200.rc8.git3.fc9.x86_64

How reproducible:
system will lock up after a certain amount of time

Steps to Reproduce:
1. leave the computer on tonight
2. move the mouse tomorrow morning
3.
  
Actual results:

Apr  7 07:57:41 localhost kernel: general protection fault: 0000 [1] SMP 
Apr  7 07:57:41 localhost kernel: CPU 0 
Apr  7 07:57:41 localhost kernel: Modules linked in: nls_utf8 ext2 usb_storage
ipt_MASQUERADE iptable_nat nf_nat bridge bnep rfcomm l2cap bluetooth autofs4
sunrpc ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp
libiscsi scsi_transport_iscsi ipt_REJECT nf_conntrack_ipv4 iptable_filter
ip_tables ip6t_REJECT xt_tcpudp nf_conntrack_ipv6 xt_state nf_conntrack
ip6table_filter ip6_tables x_tables cpufreq_ondemand acpi_cpufreq freq_table
dm_multipath ipv6 kvm_intel kvm sr_mod cdrom ata_generic snd_hda_intel i2c_i801
pcspkr ata_piix joydev sdhci serio_raw i2c_core snd_seq_dummy arc4 firewire_ohci
pata_acpi mmc_core snd_seq_oss iTCO_wdt ecb sg firewire_core iTCO_vendor_support
snd_seq_midi_event snd_seq crc_itu_t snd_seq_device snd_pcm_oss iwl4965
snd_mixer_oss snd_pcm iwlcore video output snd_timer rfkill snd_page_alloc
uvcvideo mac80211 snd_hwdep snd compat_ioctl32 e1000e videodev button ac battery
cfg80211 v4l1_compat soundcore ahci libata sd_mod scsi_mod sha256_generic cbc
aes_x86_64 aes_generic dm_cry
Apr  7 07:57:41 localhost kernel: pt crypto_blkcipher dm_snapshot dm_zero
dm_mirror dm_mod ext3 jbd mbcache uhci_hcd ohci_hcd ehci_hcd [last unloaded:
microcode]
Apr  7 07:57:41 localhost kernel: Pid: 2706, comm: Xorg Not tainted
2.6.25-0.200.rc8.git3.fc9.x86_64 #1
Apr  7 07:57:41 localhost kernel: RIP: 0010:[inotify_inode_queue_event+90/224] 
[inotify_inode_queue_event+90/224] inotify_inode_queue_event+0x5a/0xe0
Apr  7 07:57:41 localhost kernel: RSP: 0018:ffff81013cdf7eb8  EFLAGS: 00010292
Apr  7 07:57:41 localhost kernel: RAX: ff7f8101030dee80 RBX: ff7f8101030dee70
RCX: 0000000000000000
Apr  7 07:57:41 localhost kernel: RDX: 0000000000000008 RSI: ffff810130de4900
RDI: ffffffffffffffff
Apr  7 07:57:41 localhost kernel: RBP: ffff81013cdf7f08 R08: ffff8101030deed0
R09: 0000000000000001
Apr  7 07:57:41 localhost kernel: R10: ffffffff810d6df8 R11: ffff81013cdf7bc8
R12: 0000000000000001
Apr  7 07:57:41 localhost kernel: R13: ffff8101030deb00 R14: 0000000000000008
R15: 000000000139e760
Apr  7 07:57:41 localhost kernel: FS:  00007f51b578c780(0000)
GS:ffffffff8141d000(0000) knlGS:0000000000000000
Apr  7 07:57:41 localhost kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Apr  7 07:57:41 localhost kernel: CR2: 0000003017c2eb70 CR3: 0000000137c97000
CR4: 00000000000026a0
Apr  7 07:57:41 localhost kernel: DR0: 0000000000000000 DR1: 0000000000000000
DR2: 0000000000000000
Apr  7 07:57:41 localhost kernel: DR3: 0000000000000000 DR6: 00000000ffff0ff0
DR7: 0000000000000400
Apr  7 07:57:41 localhost kernel: Process Xorg (pid: 2706, threadinfo
ffff81013cdf6000, task ffff810130de4000)
Apr  7 07:57:41 localhost kernel: Stack:  0000000000000000 0000000000000000
0000000100000000 ffff8101030dee90
Apr  7 07:57:41 localhost kernel:  ffff8101030dee80 ffff8100849c7290
0000000000000001 ffff8101030deb00
Apr  7 07:57:41 localhost kernel:  0000000000000008 000000000139e760
ffff81013cdf7f38 ffffffff810add71
Apr  7 07:57:41 localhost kernel: Call Trace:
Apr  7 07:57:41 localhost kernel:  [vfs_read+287/340] vfs_read+0x11f/0x154
Apr  7 07:57:41 localhost kernel:  [sys_read+71/112] sys_read+0x47/0x70
Apr  7 07:57:41 localhost kernel:  [tracesys+213/218] tracesys+0xd5/0xda
Apr  7 07:57:41 localhost kernel: 
Apr  7 07:57:41 localhost kernel: 
Apr  7 07:57:41 localhost kernel: Code: 87 80 03 00 00 0f 84 97 00 00 00 48 8d
87 90 03 00 00 31 f6 48 89 c7 48 89 45 c8 e8 1d d5 1c 00 48 8b 83 80 03 00 00 48
8d 58 f0 <48> 8b 43 10 eb 5a 44 8b 6b 3c 44 85 6d c4 74 49 4c 8b 63 28 31 
Apr  7 07:57:41 localhost kernel: RIP  [inotify_inode_queue_event+90/224]
inotify_inode_queue_event+0x5a/0xe0
Apr  7 07:57:41 localhost kernel:  RSP <ffff81013cdf7eb8>
Apr  7 07:57:41 localhost kernel: ---[ end trace 68ae43878557ab94 ]---
Comment 1 Dominick Grift 2008-04-09 02:25:21 EDT
I feel i should note that i am not sure whether this is caused by a bug or that
this is due to some problems i have with packages that are corrupting during
updates.
Comment 2 Chuck Ebbert 2008-04-10 19:30:12 EDT
Have you tested the memory with memtest86?
Comment 3 Dominick Grift 2008-04-11 04:45:33 EDT
Yes i have tested memory to some degree (i aborted after an hour or so, there
were no errors a that point. 

This reminds me that i first used the memtest on the beta x86-64 DVD which
showed all red errors and halted unexpected. After that i tried the memtest on
the fedora 8 i386 DVD and all looked well (tested for an hour)

i have four GB memory so i might have to give that more time. Although this pc
is brand new and i gather that it has been tested before it was sold. i ran
Fedora 8 on it for a few days with no (noticable) problems

Also ive had other kernel issues due to ext/quota and since i disabled quota my
system is more stable and with todays updates its even better.

i will leave my pc on tonight to see if it hangs tomorrow morning and will
report again.
Comment 4 Dominick Grift 2008-04-12 04:29:48 EDT
Issue appears solved now. I didnt have any crashes this morning.

Thanks
Comment 5 Chuck Ebbert 2008-04-14 18:07:43 EDT
Reopen this bug if it happens again.

Note You need to log in before you can comment on or make changes to this bug.