Bug 441228 - Missing dep on pygtk2
Missing dep on pygtk2
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-python2-extras (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 06:28 EDT by Bastien Nocera
Modified: 2008-04-07 07:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 07:25:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2008-04-07 06:28:12 EDT
gnome-python2-gtkmozembed-2.19.1-14.fc9.i386

$ rpm -q --requires gnome-python2-gtkmozembed | grep pygtk2
$

The widget isn't usable without the Python GTK+ stuff, so should be required.
Comment 1 Matthew Barnes 2008-04-07 07:25:10 EDT
Looks like the problem was twofold.

The gtkmozembed subpackage was missing:

   Requires: %{name} = %{version}-%{release}

And gnome-python2 was missing an explict pygtk2 requirement (it only had a
pygtk2 build requirement, which I guess doesn't work for Python modules).

Fixed in gnome-python2-gtkmozembed-2.19.1-15.fc9 and gnome-python2-2.22.0-2.fc9.
Comment 2 Matthew Barnes 2008-04-07 07:27:09 EDT
I meant fixed in gnome-python2-extras-2.19.1-15.fc9.
                               ^^^^^^

Note You need to log in before you can comment on or make changes to this bug.