Bug 441255 - Incorrect positioning of cursor at end of message while composing
Incorrect positioning of cursor at end of message while composing
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 08:51 EDT by Paul Sorensen
Modified: 2008-07-25 11:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-25 11:02:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 292580 None None None Never

  None (edit)
Description Paul Sorensen 2008-04-07 08:51:50 EDT
Description of problem:
Under the correct conditions, cursor is positioned wrong when using the END key
to position to end of last line in message. Other strange end of message
behaviors also occur. Believe this is related to bug 292580 at
bugzilla.mozilla.org which was originally posted 2005-05-01 and still has status
of NEW.

Version-Release number of selected component (if applicable):
thunderbird-2.0.0.12-1.fc8
Also observed in earlier versions

How reproducible:
Every time with this test case

Steps to Reproduce:
1. Create this message, but don't end message with a newline

This is the first paragraph
with a second line.

This is the second paragraph
with another line
append first paragraph here

2. Position cursor at the beginning of the message with:
up up up up up home

3. Copy first paragraph with:
shift-down shift-down ctl-C

4. Position cursor at end of message with:
down down down end

5. Paste first paragraph with:
ctl-v

6. Position cursor using:
up up home down down down end

  
Actual results:
Cursor positions to paste insert point.

Expected results:
Cursor positioned at end of message.

Additional info:
The key to making this test fail, is the 3rd down in step 6. This attempts to
position the cursor beyond the end of the message. If you watch carefully, the
screen updates after this down, which would indicate something unusual happened
in the code here. The other key is to not ever end the message with a newline,
or this extra down keystroke will not cause a problem.

While there have been lots of speculation of the cause of this elusive problem
in the bug mentioned above, it would appear to be a simpler case of improper end
of buffer marking after paste or other operations. Fiddling with the cursor will
eventually cause Thunderbird to figure out the new end of buffer.
Comment 1 Matěj Cepl 2008-07-25 11:02:56 EDT
I am afraid that after all it will be better to let this bug be resolved
upstream. We don't have enough capacity to deal with it, so it would probably
stay rotenning here forever (or until closed as obsolete). Moreover, thunderbird
upstream community seems to get into second chance mode and I see them fixing
very old bugs where I have lost my hope to have them fixed.

Red Hat will continue to track the issue in the centralized upstream bug
tracker, and will review any bug fixes that become available for consideration
in future updates.

Thank you for the bug report.

Note You need to log in before you can comment on or make changes to this bug.