Bug 441263 - RFE: Provide some gui that something is happening
RFE: Provide some gui that something is happening
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-services (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 09:34 EDT by David Timms
Modified: 2016-08-10 09:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-10 09:05:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Timms 2008-04-07 09:34:49 EDT
Description of problem:
Service start stop and disable/enable fails the "1 second rule": if it looks
like nothing has happened after 1 second it looks like the application may have
failed. ie. a button click should produce immediate visible feedback and text eg
"starting", "started".

Version-Release number of selected component (if applicable):
system-config-services-0.99.14-1.fc9.noarch

Steps to Reproduce:
1. s-c-services
2. click any of enable disable start stop restart
3. clicked it again, and tried double-clicking as well.
  
Actual results:
no change for about 3 seconds. Looks like something went wrong.

Expected results:
Some nice UI feedback.

Additional info:
My preferences: progress bar {not a "knight rider" bar - they suck}. Updated
each part through the process of calling the external exec etc, with some
reasonable % complete based on typical times.

As well as eg: {and more simply}.
click enable. immediately begins flashing - one second on/one second off. once
the item is detected to have started, set start button FB off, disable feedback
goes on.

ps. the difference in the graphic for the list of plugged/unplugged items is
also to subtle. The plugged = active should be clearly active = green for going !

2ps. the enable LED for a checkconfig --levels 345 on service should be just
about as green as the green indicator. Is there many who would use runlevel 2 ?
In any case, I think the icon needs work. perhaps smaller versions of the start
and stop icons would be clearer.
Comment 1 Nils Philippsen 2016-08-10 09:05:15 EDT
Thanks for taking the time to submit this request for enhancement.
Unfortunately, I haven't gotten around to implement this feature, sorry for
that.

Because I don't actively develop system-config-services anymore, I won't likely
find the time to work on this ticket, so I'll close this bug now.

Note You need to log in before you can comment on or make changes to this bug.