Bug 441266 - uninitialized variable bug in qdiskd causes failure
uninitialized variable bug in qdiskd causes failure
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: cman (Show other bugs)
4
All Linux
low Severity low
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 09:38 EDT by Lon Hohberger
Modified: 2009-04-16 16:36 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0799
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-25 15:07:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lon Hohberger 2008-04-07 09:38:45 EDT
Description of problem:

With cman-1.0.18, a bug exists in qdiskd where, depending on what's in memory,
it fails with "Floating point exception".  This occurs because of a missing
patch in the RHEL4 branch.

Version-Release number of selected component (if applicable): 1.0.18-1

How reproducible: Sometimes


Steps to Reproduce:
1. run qdiskd -fd

Actual results:  Sometimes it fails with an error, other times it succeeds.
Expected results: Always succeed (assuming disk is available

Additional info: I found this while testing 1.0.18-1, and I think it is critical
to fix it.
Comment 1 RHEL Product and Program Management 2008-04-07 10:58:14 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 errata-xmlrpc 2008-07-25 15:07:08 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0799.html

Note You need to log in before you can comment on or make changes to this bug.