Bug 441276 - only services for a vital system should have a default runlevel list in their initscript
only services for a vital system should have a default runlevel list in their...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Canna (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 10:08 EDT by Karsten Hopp
Modified: 2008-07-30 16:00 EDT (History)
0 users

See Also:
Fixed In Version: 3.7p3-24.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-30 16:00:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2008-04-07 10:08:59 EDT
FPC and FESCo recently approved packaging guidelines for initscripts http://fedoraproject.org/wiki/Packaging/SysVInitScript . According to those guidelines only services which are really required for a vital system should define runlevels as the first parameter on the '# chkconfig: #' line in the initscript. Please consider changing the initscripts in this package.
Comment 1 Akira TAGOH 2008-04-07 22:07:17 EDT
Could you give me more info about the definition of "vital system" then? IMHO
just a few services are a must to be run at the boot up time though, after
looking around bugzilla, I'm not quite sure what that is. and it may depends if
it's running as a server or desktop etc. in that sense httpd, samba and sendmail
even doesn't need to be run. which wasn't filed.
Comment 2 Karsten Hopp 2008-04-08 06:16:51 EDT
httpd has 'chkconfig: - 85 15'
samba has 'chkconfig: - 91 35' for nmb and 'chkconfig: - 91 35' for smb

So those two didn't need a bugzilla.

sendmail is a 'vital' package as it is required to deliver local mail from cron
jobs and such.

Canna might be vital for machines configured for japanese locales but aren't of
any value for all other systems. I didn't check your initscript besides the
chkconfig line, do you check /etc/sysconfig/i18n and bail out without starting
the service when the language setting isn't ja_* ? In that case using default
runlevels would be ok.

Comment 3 Akira TAGOH 2008-04-08 06:54:22 EDT
Sure. thank you for clarification. since the locale can be set up differently
per users, determining from the system locale if the service should be running
or not wouldn't be a good idea. so I just got rid of them from the initscript in
3.7p3-24.
Comment 4 Fedora Update System 2008-05-14 03:39:16 EDT
Canna-3.7p3-24.fc9 has been submitted as an update for Fedora 9
Comment 5 Bug Zapper 2008-05-14 05:02:48 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Fedora Update System 2008-05-14 18:11:08 EDT
Canna-3.7p3-24.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Canna'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-3895
Comment 7 Fedora Update System 2008-07-30 16:00:23 EDT
Canna-3.7p3-24.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.