Bug 441322 - yum search crashes
yum search crashes
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 10:57 EDT by Pierre-Yves
Modified: 2014-01-21 18:02 EST (History)
6 users (show)

See Also:
Fixed In Version: yum-3.2.14-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-10 03:40:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre-Yves 2008-04-07 10:57:34 EDT
Description of problem:
When I type yum search I got some line of code as output and no results

Version-Release number of selected component (if applicable):
yum-3.2.13-2.fc9.noarch


How reproducible:
always

Steps to Reproduce:
1.yum search ftp
2.yum search R
3.Read
  
Actual results:
it returns this :

 yum search R
Loaded plugins: presto, refresh-packagekit
Setting up and reading Presto delta metadata
No Presto metadata available for livna-development
No Presto metadata available for rawhide
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 236, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 111, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 309, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd,
self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 498, in doCommand
    return base.search(extcmds)
  File "/usr/share/yum-cli/cli.py", line 690, in search
    for (po, keys, matched_value) in matching:
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 1505, in
searchGenerator
    value = unicode(value,'unicode-escape')
UnicodeDecodeError: 'unicodeescape' codec can't decode bytes in position
131-133: truncated \uXXXX escape


Expected results:
a list of package containning ftp or R in their name/summary
Comment 1 Seth Vidal 2008-04-08 01:50:32 EDT
Please try yum 3.2.14 in rawhide and let us know if this still happens.
Comment 2 Johan Cwiklinski 2008-04-08 12:31:42 EDT
It seems to be ok with these version :)
Comment 3 Pierre-Yves 2008-04-10 03:40:24 EDT
It also works here for me, so I close the bug 

Thanks guys :)

Note You need to log in before you can comment on or make changes to this bug.