Bug 441385 - soundcard not always been detected
soundcard not always been detected
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 16:02 EDT by Dmytro Ozirny
Modified: 2008-04-16 10:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 14:08:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
grep pulseaudio /var/log/messages (7.06 KB, text/plain)
2008-04-08 14:02 EDT, Dmytro Ozirny
no flags Details
my dmesg (22.63 KB, text/plain)
2008-04-08 14:12 EDT, Dmytro Ozirny
no flags Details
my lsmod (4.05 KB, text/plain)
2008-04-08 14:13 EDT, Dmytro Ozirny
no flags Details
my lspci (1.52 KB, text/plain)
2008-04-08 14:13 EDT, Dmytro Ozirny
no flags Details
requested strace of aplay (5.84 KB, text/plain)
2008-04-08 14:20 EDT, Dmytro Ozirny
no flags Details

  None (edit)
Description Dmytro Ozirny 2008-04-07 16:02:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ru; rv:1.8.1.13) Gecko/20080325 Fedora/2.0.0.13-1.fc8 Firefox/2.0.0.13

Description of problem:
on rare ocassions I can get sound from my soundcard, but mostly not.
I have i865PE chipset, soundcard integrated (AC'97).
I've installed packets by default, later added driver for my NVidia 7600 GS AGP and updated all packets - that's all.

Version-Release number of selected component (if applicable):
pulseaudio.0.9.8-5

How reproducible:
Sometimes


Steps to Reproduce:
nothing to do. Just start Fedora 8 - sometimes you have sound working, sometimes not.

Actual Results:


Expected Results:


Additional info:
Comment 1 Lubomir Kundrak 2008-04-07 16:10:03 EDT
Please have a look here, and see if you can provide more information:
http://fedoraproject.org/wiki/LubomirKundrak/SoundTroubleshooting
Comment 2 Dmytro Ozirny 2008-04-08 13:56:31 EDT
Additional info:

ALSA:

[diz@myhost ~]$ yum list installed |grep kernel
kernel.i686                              2.6.24.4-64.fc8        installed
kernel.i686                              2.6.24.3-50.fc8        installed
[diz@myhost ~]$ yum list installed |grep alsa-lib
alsa-lib.i386                            1.0.15-1.fc8           installed
[diz@myhost ~]$ yum list installed |grep alsa-plugins-pulseaudio

I've deinstalled alsa-plugins-pulseaudio, because it was suggested on some forum.

[diz@myhost ~]$ yum list installed |grep hal
hal.i386                                 0.5.10-1.fc8.2         installed
hal-info.noarch                          20071030-1.fc8         installed
hal-libs.i386                            0.5.10-1.fc8.2         installed

[diz@myhost ~]$ getfacl /dev/snd/pcmC0D0c
getfacl: Removing leading '/' from absolute path names
# file: dev/snd/pcmC0D0c
# owner: root
# group: root
user::rw-
user:diz:rw-
group::rw-
mask::rw-
other::---

[diz@myhost ~]$ yum list installed |grep ConsoleKit
ConsoleKit.i386                          0.2.3-3.fc8.1          installed
ConsoleKit-libs.i386                     0.2.3-3.fc8.1          installed
ConsoleKit-x11.i386                      0.2.3-3.fc8.1          installed

[diz@myhost ~]$ ck-list-sessions
Session1:
        uid = '500'
        realname = 'Dmytro Surname'
        seat = 'Seat1'
        session-type = ''
        active = TRUE
        x11-display = ':0'
        x11-display-device = '/dev/tty7'
        display-device = ''
        remote-host-name = ''
        is-local = TRUE
        on-since = '2008-04-08T17:41:20Z'

[diz@myhost ~]$ alsamixer -c 0
No mixer elems found

[diz@myhost ~]$ aplay -D hw:0 /usr/share/sounds/startup3.wav
aplay: main:546: audio open error: No such file or directory
Comment 3 Dmytro Ozirny 2008-04-08 14:02:15 EDT
Created attachment 301670 [details]
grep pulseaudio /var/log/messages
Comment 4 Dmytro Ozirny 2008-04-08 14:02:54 EDT
Pulseaudio:

In GNOME see System->Preferences->Personal->Sessions: I can see PulseAudio
Session Management starts here.

[diz@myhost ~]$ ps aux |grep pulseaudio
diz       2630  0.0  0.4  23604  4176 ?        Sl   20:41   0:00
/usr/bin/pulseaudio --log-target=syslog

Comment 5 Lubomir Kundrak 2008-04-08 14:06:49 EDT
(In reply to comment #2)

> I've deinstalled alsa-plugins-pulseaudio, because it was suggested on some forum.

Though this is most likely unrelated, it was not a good idea, as it's pretty
crucial part of sound system in a modern Linux desktop. 

> [diz@myhost ~]$ alsamixer -c 0
> No mixer elems found

> [diz@myhost ~]$ aplay -D hw:0 /usr/share/sounds/startup3.wav
> aplay: main:546: audio open error: No such file or directory

This seems like your sound card was really not detected at all. Before we
reassign to kernel, please attach output of dmesg(8) and paste output of
lsmod(8), lspci(8) and "hal-find-by-capability --capability alsa".

Thanks!
Comment 6 Dmytro Ozirny 2008-04-08 14:07:49 EDT
[diz@myhost ~]$ hal-find-by-capability --capability alsa
/org/freedesktop/Hal/devices/computer_alsa_timer
/org/freedesktop/Hal/devices/computer_alsa_sequencer
/org/freedesktop/Hal/devices/usb_device_c45_608f_noserial_if1_alsa_capture_0
/org/freedesktop/Hal/devices/usb_device_c45_608f_noserial_if1_alsa_control__1

Comment 7 Lubomir Kundrak 2008-04-08 14:11:59 EDT
(In reply to comment #6)
> /org/freedesktop/Hal/devices/usb_device_c45_608f_noserial_if1_alsa_capture_0
> /org/freedesktop/Hal/devices/usb_device_c45_608f_noserial_if1_alsa_control__1

Soo, it's an USB soundcard.

> [diz@myhost ~]$ aplay -D hw:0 /usr/share/sounds/startup3.wav
> aplay: main:546: audio open error: No such file or directory

I'm wondering what file was missing. If it was that startup3.wav, use any other
wav file. In case it's not the one, please attach output of:

strace -f aplay -D hw:0 /usr/share/sounds/startup3.wav 2>&1 |tee
output-to-attach.log
Comment 8 Dmytro Ozirny 2008-04-08 14:12:43 EDT
Created attachment 301674 [details]
my dmesg
Comment 9 Dmytro Ozirny 2008-04-08 14:13:04 EDT
Created attachment 301676 [details]
my lsmod
Comment 10 Dmytro Ozirny 2008-04-08 14:13:22 EDT
Created attachment 301677 [details]
my lspci
Comment 11 Dmytro Ozirny 2008-04-08 14:19:37 EDT
(In reply to comment #7)
> (In reply to comment #6)
> > /org/freedesktop/Hal/devices/usb_device_c45_608f_noserial_if1_alsa_capture_0
> > /org/freedesktop/Hal/devices/usb_device_c45_608f_noserial_if1_alsa_control__1
> 
> Soo, it's an USB soundcard.

No, it's not. I have USB mouse and USB webcam Genius (with mic).

> > [diz@myhost ~]$ aplay -D hw:0 /usr/share/sounds/startup3.wav
> > aplay: main:546: audio open error: No such file or directory
> 
> I'm wondering what file was missing. If it was that startup3.wav, use any other
> wav file. In case it's not the one, please attach output of:
> 
> strace -f aplay -D hw:0 /usr/share/sounds/startup3.wav 2>&1 |tee
> output-to-attach.log

[diz@myhost ~]$ file /usr/share/sounds/startup3.wav
/usr/share/sounds/startup3.wav: RIFF (little-endian) data, WAVE audio, Microsoft
PCM, 16 bit, stereo 44100 Hz

[diz@myhost ~]$ locate aplay
/usr/bin/aplay
................


Now I'll attach strace
Comment 12 Dmytro Ozirny 2008-04-08 14:20:17 EDT
Created attachment 301678 [details]
requested strace of aplay
Comment 13 Lubomir Kundrak 2008-04-08 14:25:34 EDT
dmesg:

> ALSA sound/core/init.c:137: cannot find the slot for index 0 (range 0-1),
error: -16
> Intel ICH: probe of 0000:00:1f.5 failed with error -12

Certainly an ALSA/kernel problem -- reassigning.
Comment 14 Dmytro Ozirny 2008-04-08 14:39:51 EDT
I've installed alsa-plugins-pulseaudio, as you suggested, but still no changes
(no sound).
Comment 15 Lennart Poettering 2008-04-09 11:43:40 EDT
I am pretty sure this is an issue caused by a bogus modprobe.conf fragment that
is a leftover from s-c-s.

Please check /etc/modprobe.conf and /etc/modprobe.d/* for any lines that
hardcode a sound card index to a specific sound driver mapping and remove them.
Comment 16 Dmytro Ozirny 2008-04-09 13:41:18 EDT
I must say I'm new to Fedora. Before that I worked with FreeBSD so please tell
me what is s-c-s?
Comment 17 Dmytro Ozirny 2008-04-09 14:08:39 EDT
Thanks, it helped. I've removed next lines:

[diz@myhost ~]$ diff modprobe.conf.orig /etc/modprobe.conf
6,7d5
< options snd-card-0 index=0
< options snd-intel8x0 index=0
9,10d6
< options snd-card-1 index=1
< options snd-mpu401 index=1

and now for 3 boots I still have sound succesfully working.
I guess you may close it now. Thanks again.
Comment 18 Lennart Poettering 2008-04-16 10:43:49 EDT
s-c-s is system-config-soundcard. A graphical utility that was part of the
install process in old versions of Fedora and is nowadays obselete.

Note You need to log in before you can comment on or make changes to this bug.