Bug 441387 - rhn_register fails
rhn_register fails
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration (Show other bugs)
unspecified
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Justin Sherrill
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 16:08 EDT by maurice
Modified: 2008-12-23 12:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-23 12:24:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description maurice 2008-04-07 16:08:37 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
I have:
A valid Red Hat login &  account for this machine
A Red Hat Installation Number

On the machine I need to run
    "rhn_register"

When I do so it takes me to a screen that says:

Please enter your login information for the 
https://intel7.lsf.platform.com/XMLRPC Red Hat Network Satellite:
Login: ____________________                     â
Password: ____________________                     â

When I enter the (valid) user and password for the Red Hat subscription I want
to assign, I get an error, and it quits.

===================================
  
Actual results:

Here is the error:

===================================
[root@localhost-eth0 ~]# rhn_register
An error has occurred:

Error Class Code: 2
Error Class Info: Invalid username and password combination.
Explanation:
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

See /var/log/up2date for more information
===================================
If I look there I see:

===================================
[root@localhost-eth0 ~]# less /var/log/up2date
[Mon Apr  7 11:48:55 2008] up2date logging into up2date server
[Mon Apr  7 11:49:00 2008] up2date Error communicating with server. The message
was:

Error Message:
    Satellite Certificate has expired
Error Class Code: 3006
Error Class Info: Invalid satellite certificate
Explanation:
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

[Mon Apr  7 13:36:40 2008] rhn_register
Traceback (most recent call last):
  File "/usr/sbin/rhn_register", line 79, in ?
    app.run()
  File "/usr/share/rhn/up2date_client/rhncli.py", line 65, in run
    sys.exit(self.main() or 0)
  File "/usr/sbin/rhn_register", line 64, in main
    ui.main()

Expected results:
Successful machine registration

Additional info: Called tech support, who were not able to help ( or, frankly,
even comprehend the error!)
Comment 1 Clifford Perry 2008-12-23 12:24:44 EST
    Satellite Certificate has expired

Hi there, 
The above piece of information says exactly what has happened. The Satellite Administrator's certificate has expired and thus service of clients is being denied. 

I suspect this has long since been resolved. If not, please have the Satellite Administrator open a support ticket for this and/or contact Sales, if a renewal is needed. 

Regards,
Clifford.

Note You need to log in before you can comment on or make changes to this bug.