This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 441408 - Openoffice exits at startup when using Xinerama
Openoffice exits at startup when using Xinerama
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 17:47 EDT by Leo Lopes
Modified: 2008-04-09 19:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-08 09:55:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leo Lopes 2008-04-07 17:47:03 EDT
Description of problem: 

After enabling Xinerama, starting any ooffice program results in a sequence of X
errors and a normal exit (return code 0)


Version-Release number of selected component (if applicable):

openoffice.org-core-2.3.0-6.5.fc7
xorg-x11-drv-nvidia-96xx-96.43.05-4.lvn7
xorg-x11-server-Xorg-1.3.0.0-16.fc7


How reproducible:

Allways

Steps to Reproduce:
1. Enable Xinerama in xorg.conf
2. restart X
3. try to start any openoffice product.
  
Actual results:
[me@mybox ~]$ oowriter 
X-Error: BadMatch (invalid parameter attributes)
        Major opcode: 78 (X_CreateColormap)
        Resource ID:  0x0
        Serial No:    111 (111)
X-Error: BadColor (invalid Colormap parameter)
        Major opcode: 84 (X_AllocColor)
        Resource ID:  0x2a00003
        Serial No:    113 (113)
X-Error: BadColor (invalid Colormap parameter)
        Major opcode: 84 (X_AllocColor)
        Resource ID:  0x2a00003
        Serial No:    115 (115)
X-Error: BadColor (invalid Colormap parameter)
X-Error: BadColor (invalid Colormap parameter)
        Major opcode: 1 (X_CreateWindow)
        Resource ID:  0x2a00003
        Serial No:    117 (117)
X-Error: BadWindow (invalid Window parameter)
        Major opcode: 18 (X_ChangeProperty)
        Resource ID:  0x2a00004
        Serial No:    119 (119)
X-Error: BadWindow (invalid Window parameter)
        Major opcode: 18 (X_ChangeProperty)
        Resource ID:  0x2a00004
        Serial No:    121 (121)

<snip/>

X-Error: BadColor (invalid Colormap parameter)
        Major opcode: 1 (X_CreateWindow)
        Resource ID:  0xa9
        Serial No:    264 (264)
[me@mybox ~]$

Expected results:

Openoffice should start.

Additional info:

I had to set

Section "Extensions"
        Option "Composite" "false"
EndSection

in xorg.conf to get gnome-terminal to work.
Comment 1 Caolan McNamara 2008-04-07 17:56:00 EDT
Try the opengl (though this doesn't look like that problem) workaround at
http://fedoraproject.org/wiki/OpenOffice.org and also attach your
/var/log/Xorg.log and ensure that the nvidia driver is the very latest.

A problem is that we're talking about a 3rd party proprietary driver. If this is
reproducible with another driver then I'm very interested. But the nvidia
drivers are a tale of unending woe
Comment 2 Caolan McNamara 2008-04-08 04:53:14 EDT
What happens if you run glxgears ?
Comment 3 Caolan McNamara 2008-04-08 09:55:49 EDT
Checkout around with google on those errors and nvidia I see quite a few reports
about this wrt opengl using apps (like OOo is), so it looks like a generic issue
and not specific to OOo.
Comment 4 Leo Lopes 2008-04-09 19:26:13 EDT
Thanks for the help. Here are the resuts of your suggestions:

from Comment #1) adding SAL_NOOPENGL or SAL_DISABLE_CAIROTEXT made no difference. 

from Comment #2) glxinfo does return a similar "BadMatch" error.

I tried changing to the NV driver but X did not start, saying that a resource
was already in use. It turns out the nv driver does not support dual head over
one card.

When I turn Xinerama off, at least I can run ooffice. In this new configuration
(no Xinerama), glxinfo causes X to crash immediately. It looks safe to say that
the problem is an nvidia issue.

Note You need to log in before you can comment on or make changes to this bug.