Bug 441417 - Newer systemtap required for R2 & MRG kernels
Newer systemtap required for R2 & MRG kernels
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-utilities (Show other bugs)
beta
x86_64 All
low Severity high
: ---
: ---
Assigned To: Luis Claudio R. Goncalves
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 18:24 EDT by IBM Bug Proxy
Modified: 2008-06-03 02:24 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.6.24.7-62.el5rt
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-02 15:12:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 43816 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-04-07 18:24:23 EDT
=Comment: #0=================================================
Ankita Garg <ankigarg@in.ibm.com> - 2008-04-04 06:02 EDT
Problem description:

Using systemtap on RHEL5.1 with R2 or MRG kernel yields the following error:

Pass 3: translated to C into
"/tmp/stap5RoyjI/stap_8a5439dfd73f3c78e9d2d98f6ac0537b_3446.c" in
0usr/0sys/0real ms.
Running make -C "/lib/modules/2.6.24.4-30ibmrt2.2/build" M="/tmp/stap5RoyjI"
modules V=1
make: Entering directory `/usr/src/kernels/2.6.24.4-30ibmrt2.2-x86_64'
test -e include/linux/autoconf.h -a -e include/config/auto.conf || (            \
        echo;                                                           \
        echo "  ERROR: Kernel configuration is invalid.";               \
        echo "         include/linux/autoconf.h or include/config/auto.conf are
missing.";      \
        echo "         Run 'make oldconfig && make prepare' on kernel src to fix
it.";  \
        echo;                                                           \
        /bin/false)
mkdir -p /tmp/stap5RoyjI/.tmp_versions ; rm -f /tmp/stap5RoyjI/.tmp_versions/*
make -f scripts/Makefile.build obj=/tmp/stap5RoyjI
+ gcc '-DKBUILD_BASENAME="stap_8a5439dfd73f3c78e9d2d98f6ac0537b_3446"' -Werror
-S -o /dev/null -xc /usr/share/systemtap/runtime/autoconf-hrtimer-rel.c
/usr/share/systemtap/runtime/autoconf-hrtimer-rel.c:1:27: error:
linux/hrtimer.h: No such file or directory
/usr/share/systemtap/runtime/autoconf-hrtimer-rel.c:3: error: 'HRTIMER_REL'
undeclared here (not in a function)
+ echo ''
+ gcc '-DKBUILD_BASENAME="stap_8a5439dfd73f3c78e9d2d98f6ac0537b_3446"' -Werror
-S -o /dev/null -xc /usr/share/systemtap/runtime/autoconf-inode-private.c
/usr/share/systemtap/runtime/autoconf-inode-private.c:6: error: variable 'i' has
initializer but incomplete type
/usr/share/systemtap/runtime/autoconf-inode-private.c:6: error: unknown field
'i_private' specified in initializer
cc1: warnings being treated as errors
/usr/share/systemtap/runtime/autoconf-inode-private.c:6: warning: excess
elements in struct initializer
/usr/share/systemtap/runtime/autoconf-inode-private.c:6: warning: (near
initialization for 'i')
+ echo ''
scripts/Makefile.build:46: *** CFLAGS was changed in "/tmp/stap5RoyjI/Makefile".
Fix it to use EXTRA_CFLAGS.  Stop.
make: *** [_module_/tmp/stap5RoyjI] Error 2
make: Leaving directory `/usr/src/kernels/2.6.24.4-30ibmrt2.2-x86_64'
Pass 4: compiled C into "stap_8a5439dfd73f3c78e9d2d98f6ac0537b_3446.ko" in
330usr/300sys/974real ms.
Pass 4: compilation failed.  Try again with more '-v' (verbose) options.
Running rm -rf /tmp/stap5RoyjI


This is using a simple stap script:

probe syscall.open {
        printf("hit\n")
}

If this is a customer issue, please indicate the impact to the customer:
Yes. We would like the customer to be able to use systemtap on the real-time kernels


This issue has been fixed in the recent systemtap source. So, request RedHat to
consider packaging newer systemtap rpm for MRG kernel.

stap version shipped:
]# stap -v
A script must be specified.
SystemTap translator/driver (version 0.5.14/0.128 built 2007-07-03)
Copyright (C) 2005-2007 Red Hat, Inc. and others
This is free software; see the source for copying conditions.
Comment 1 Frank Ch. Eigler 2008-04-08 20:56:33 EDT
A systemtap build labeled 0.6.2 was released into brew toward rhel and fedora
recently.  It appears to have just missed an upstream fix for this problem.

http://sources.redhat.com/git/?p=systemtap.git;a=commitdiff;h=ecf194547a1efcc82a6f77862a25c9327f55d011
Comment 2 Clark Williams 2008-04-23 17:06:29 EDT
Luis,

Is there anything we can do here with the supported systemtap (as opposed to
trying to use a rawhide version)?

Can we automate the "fixup" to the Makefile?

Clark
Comment 3 Frank Ch. Eigler 2008-04-23 17:22:33 EDT
We're working on a refresh for bug #443861 that will include this patch.
Comment 4 Frank Ch. Eigler 2008-04-25 13:52:38 EDT
Try systemtap-0.6.2-2.el5 in brew.
Comment 5 IBM Bug Proxy 2008-05-07 10:40:57 EDT
------- Comment From sripathi@in.ibm.com 2008-05-07 10:34 EDT-------
Copying Ankita's comment as an external comment:
(In reply to comment #11)
> ------- Comment From fche@redhat.com 2008-04-25 13:52 EST-------
> Try systemtap-0.6.2-2.el5 in brew.

Yes, with this version of systemtap rpm, I do not hit the error reported.
Comment 6 IBM Bug Proxy 2008-05-15 07:16:49 EDT
------- Comment From sripathi@in.ibm.com 2008-05-15 07:16 EDT-------
To RH: Are you going to carry systemtap-0.6.2-2.el5 rpm in MRG repo until MRG is
rebased to RHEL5.2?
Comment 7 Clark Williams 2008-05-27 18:18:42 EDT
The guys that manage the mrg-beta repository pulled the 5.2 packages when 5.2
GA'ed. I suspect that we'll need to put them back, since we're probably going to
have to support MRG-RT on both 5.1 and 5.2

Clark
Comment 8 Frank Ch. Eigler 2008-05-27 18:28:48 EDT
systemtap-0.6.2-2.el5 should run just fine on rhel5.1 kernels.
Comment 9 IBM Bug Proxy 2008-06-02 14:00:27 EDT
------- Comment From dvhltc@us.ibm.com 2008-06-02 13:57 EDT-------
This appears to be in the mrg-beta repo again, and IBM is now based on 5.2.  I
think we can close this.
Comment 10 Clark Williams 2008-06-02 15:12:31 EDT
closing
Comment 11 IBM Bug Proxy 2008-06-03 02:24:27 EDT
------- Comment From sripathi@in.ibm.com 2008-06-03 02:23 EDT-------
Closing on our side as well.

Note You need to log in before you can comment on or make changes to this bug.