Bug 441475 - Dist Tag Restrictions
Dist Tag Restrictions
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: samba (Show other bugs)
4.7
All Linux
low Severity low
: rc
: ---
Assigned To: Guenther Deschner
qe-baseos-daemons
:
: 452496 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-08 07:34 EDT by Martin Kočí
Modified: 2010-05-10 10:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-10 10:47:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kočí 2008-04-08 07:34:04 EDT
Description of problem:
As definition says - %{?dist} means to use the value of 'dist' if it is defined,
or leave it out otherwise. %{dist} means to use it unconditionally, which
generates a failure if it is not defined. This causes known issues under RHEL4,
and the Release Engineering policy is to use %{?dist} and not %{dist}.

Version-Release number of selected component (if applicable):
samba-3.0.28-0.el4.4.src.rpm

How reproducible:
Check SPEC file.

Actual results:
%{dist}

Expected results:
%{?dist}
Comment 1 Simo Sorce 2008-12-17 13:40:46 EST
Forgot about this one, will fix in the next release.
Comment 3 Dmitri Pal 2010-05-10 10:47:46 EDT
*** Bug 452496 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.