Bug 441528 - ftrace doesn't work at all
ftrace doesn't work at all
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: frysk (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Eric Bachalo
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-08 12:09 EDT by Petr Muller
Modified: 2016-09-19 22:04 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-15 04:38:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Petr Muller 2008-04-08 12:09:45 EDT
Description of problem:
I haven't been succesful when running a command under ftrace. If I attach to 
some already running pid, everything seems to be ok. But if I run direct 
command, then nothing happens and the program seems to never end. I wasn't able 
to run any of the examples from the man page.

Version-Release number of selected component (if applicable):
frysk-0.0.1.2008.03.19.rh1-1.el5

How reproducible:
seems like always

Steps to Reproduce:
1. ftrace -sys= ls (but any options can be used, none works)
2. see execvp: No such file or directory error message
  
Actual results:
no workie workie

Expected results:
ls output is shown, along with the captured syscalls

Additional info:
# ftrace -sys= -- ls
execvp: No such file or directory
Comment 1 Mark Wielaard 2008-04-08 12:14:53 EDT
This is similar to this fedora bug report:
https://bugzilla.redhat.com/show_bug.cgi?id=440323

Workaround for now, use full absolute paths to the binary you want to frace: 
ftrace -sys= /bin/ls
Comment 2 Andrew Cagney 2008-04-08 14:12:28 EDT
fixed upstream

Note You need to log in before you can comment on or make changes to this bug.