Bug 441534 - session restore doesn't place windows properly
session restore doesn't place windows properly
Status: CLOSED DUPLICATE of bug 443129
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-08 12:18 EDT by Charles R. Anderson
Modified: 2014-06-18 05:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-07 10:51:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charles R. Anderson 2008-04-08 12:18:40 EDT
Description of problem:

I have a dual-head setup with xrandr configured in xorg.conf so that both
monitors are active before logging in.  When having gnome-session save the
session automatically, the applications are restarted on login, but the windows
are placed incorrectly.  It appears at first that the windows are placed
properly as they flash for an instant at the correct locations, but then they
disappear and reappear all stacked up on each other on the left display.  For
example, the six or seven gnome-terminal windows all end up stacked on top of
each other on the left screen on one virtual desktop, while they were originally
tiled over several virtual desktops on both monitors.

Version-Release number of selected component (if applicable):
gnome-session-2.22.1-1.fc9.i386


How reproducible:
always

Steps to Reproduce:
1. Preferences->Personal>Sessions->Session Options->Automatically remember
running applications when logging out
2. Open a bunch of gnome terminals, spread throughout virtual desktops and
different monitors.
3. System->Log out
4. Log back in, notice that gnome terminals flash for an instant in their proper
locations, then disappear and reappear all stacked on top of each other on the
corner of one virtual desktop on one of the monitors.
Comment 1 Matthias Clasen 2008-04-11 10:54:25 EDT
Are you using compiz or metacity ?
Comment 2 Charles R. Anderson 2008-04-11 11:02:23 EDT
metacity
Comment 3 Charles R. Anderson 2008-04-16 17:24:27 EDT
Upon further investigation, this appears to only happen to gnome-terminal
windows.  Evince, Firefox, OpenOFfice, Pidgin, and Rhythmbox all restored to
their proper locations.  Could this be a gnome-terminal bug?  Reassigning...
Comment 4 Doug Ledford 2008-05-07 10:48:21 EDT
I'm seeing the same issue, but I don't need a dual head setup to reproduce, it
does it just fine on a single head setup.  The issue appears to be (from what I
can tell anyway) that gnome-terminal doesn't like being started with saved
session state that results in overlapping windows.  Aka, I always setup a 4
terminal array, 2 on top, 2 on bottom, and the 2 on top slightly overlap the two
on bottom in order to cover the window title bar and get me a few extra display
lines on the screen.  Saving this setup and then relogging causes three of the
four windows to stack (and also resize back to default terminal size, where as
they were 80x34 on top and 80x30 on bottom IIRC).  The only one that doesn't
resize and restack is the lower right window.
Comment 5 Doug Ledford 2008-05-07 10:51:08 EDT
This looks to be a duplicate of another bug, and since the other bug has a
workaround in the comments and this one doesn't, I'm marking this bug a
duplicate of that one.

*** This bug has been marked as a duplicate of 443129 ***

Note You need to log in before you can comment on or make changes to this bug.