Bug 441578 - MMC, MS Pro, xD cards nonfunctional on Dell M6300 (Converse) laptop
MMC, MS Pro, xD cards nonfunctional on Dell M6300 (Converse) laptop
Status: CLOSED DUPLICATE of bug 253141
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: John Feeney
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-08 16:14 EDT by Zack Cerza
Modified: 2008-04-10 13:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-10 13:51:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zack Cerza 2008-04-08 16:14:04 EDT
Description of problem:
I don't know if all of these are supposed to be supported, but I did discover a
hack for making MMC work:

/sbin/setpci -s '03:01.0' 0xCA=0x57
/sbin/setpci -s '03:01.0' 0xCB=0x02
/sbin/setpci -s '03:01.0' 0xCA=0x00

Here's a snippet from lspci -n:
03:01.0 0c00: 1180:0832 (rev 05)
03:01.1 0805: 1180:0822 (rev 22)
03:01.2 0880: 1180:0843 (rev 12)
03:01.3 0880: 1180:0592 (rev 12)
03:01.4 0880: 1180:0852 (rev ff)


Let me know if I should file separate bugs.

Version-Release number of selected component (if applicable):
kernel-2.6.18-88.el5.x86_64
Comment 1 Zack Cerza 2008-04-10 13:51:57 EDT

*** This bug has been marked as a duplicate of 253141 ***

Note You need to log in before you can comment on or make changes to this bug.